
Precision Valve & Automation
Six Corporate Drive

Halfmoon, NY 12065
www.pva.net 

PathMaster®
Owner’s Manual 

Revision L 

WHERE  

PRECISION 

DRIVES  

PRODUCTION 



PathMaster PVA    
 

Revision K  (2019) 2 of 200 
 

This document is based on information available at the time of its publication. 

While efforts have been made to ensure the contents of this manual are 

accurate, the information contained herein does not purport to cover all 

specific details or variations in hardware, or to provide for every possible 

contingency in connection with installation, operation, or maintenance. 

Features may be described herein which are not present in all hardware and 

software systems. Precision Valve and Automation, Inc. assumes no obligation 

of notice to holders of this document with respect to changes subsequently 

made. 

Precision Valve and Automation, Inc. makes no representation or warranty, 

expressed, implied, or statutory with respect to, and assumes no responsibility 

for the accuracy, completeness, sufficiency, or usefulness of the information 

contained herein. No warranties of merchantability or fitness for purpose shall 

apply. 

This document, including the information contained herein, is the property of 

Precision Valve and Automation, Inc. and is considered confidential and 

proprietary information. It is delivered on the express condition that it not be 

used, disclosed, or reproduced, in whole or in part, for any reason without prior 

written consent of Precision Valve and Automation, Inc.  

 

Copyright © 2020 

Precision Valve and Automation, Inc. 

All Rights Reserved. 
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 Introduction 
Before you operate this system, read the operation and setup manual. This 
will help you to become familiar with the product and ensure successful 
operation. 

If any questions or problems arise, contact PVA’s Technical Support 
department. 

PVA Contact Information 

Main Office   PVA  

   One Mustang Drive  

   Cohoes, NY 12047 

   Tel +1-518-371-2684 

   Fax +1-518-371-2688 

   Website: http://www.pva.net 

    Email: info@pva.net 

Technical Support  

Tel +1-844-734-0209 

   Email: cs@pva.net 

 Document History 

Revision Revision Date Reason for Changes 
REV L February 2020 Passwords updated, New Template 
REV K January 2019 4.5 PathMaster Release  
REV J May 2018 IP Addresses Added 
REV I May 2018 4.4 PathMaster Release 
REV H February 2018 Additional 4.3 Release Updates 
REV G February 2018 4.3 PathMaster Release 
REV F April 2017 Update of INI Content 
REV E March 2017 PathMaster 4.2 Release 
REV D October 2016 Added Notice on PathMaster.ini File  
REV C April 2016 Save for Part Manager and Motion Smoothing 
REV B January 2015 4.1 PathMaster Release 
REV A October 2013 Initial Release 

Note: All photographs and CAD model representations in this document are a 
“general representation” of the system and its components. The actual 
appearance of the system and its components can differ based upon 
customer specific configuration. 

http://www.pva.net/
mailto:info@pva.net
mailto:cs@pva.net
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 Safety 

Certain warning symbols are affixed to the machine and correspond to 
notations in this manual. Before operating the system, identify these 
warning labels and read the notices described below. Not all labels may be 
used on any specific system. 

 

Always wear approved safety glasses when you operate or work near 
the workcell. 

 

Before you operate the system, read and understand the manuals 
provided with the unit. 

 

Never put hands or tools in areas with this symbol when the machine 
is in operation. A dangerous condition may exist. 

 

Read and understand the manuals provided with the unit before any 
repairs or maintenance is done. Only a qualified individual should do 
service. 

 

Use caution when there are pressurized vessels. Find and repair any 
leaks immediately. Always wear appropriate safety equipment when 
you work with pressurized vessels or vessels that contain chemicals 

 

Shear hazard from moving parts. Avoid contact. 

 

Do not remove protective guarding. 

 

In situations where inattention could cause either personal injury or 
damage to equipment, a warning notice is used. 
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Do not smoke near the PVA UV cure machine. Always have a fire 
extinguisher available for emergency use. 

 

Before performing any repairs or maintenance to the system, turn off 
power and lock out the power disconnect switch. 

 

Warning notices are used to emphasize that hazardous voltages, 
current, temperatures, or other conditions that could cause personal 
injury exist in this equipment or may be associated with its use. Only 
qualified personnel should enter areas designated with this symbol. 

 

Laser light source present. Do not stare directly into the beam. Do not 
use in the presence of highly reflective surfaces 

 

Pinch hazard from moving parts. Avoid contact. 

 

Hot surface. Avoid contact. 

 

Warning, Ultraviolet (UV) light hazard. Do not look directly at the UV 
light source. 
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 Theory of Operation  

This manual applies to the following Precision Valve & Automation, Inc. 
workcells:  

PVA350™ PVA6000™ 

PVA650™ Delta 6  

PVA2000™ Delta 8 

PVA3000™  

Some features may not apply due to specific hardware and the version of 
PVA Portal installed on the workcell. Please contact PVA for more 
information. All machines are referenced in the manual as workcells. This 
manual gives information on common options and configurations for a 
workcell. The machine related to this manual may not contain all items or 
may have additions. If the manual refers to an option that was not 
purchased, ignore that section. If there are options on the workcell not 
included in this manual, refer to the workcell manual for more information. 

NOTE: Always wear gloves when handling materials and solvents. Refer to 
MSDS sheets on the material dispensed for other precautions. 

 Waste Disposal  

Dispose of all used parts and materials in accordance with local laws and 
regulations.  
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 Hardware and Software Requirements 

PathMaster® requires an Intel® Core i5 processor or equivalent processor 
with 4 Gigabytes of RAM, 2 Gigabytes free hard drive space and Windows® 10 
Operating System or newer. Your computer must also have: 

• (2) Ethernet ports  

• (1) RS232 serial communications 
port 

• 17” monitor with 1280 x 1024 
resolution 

•   Mouse (USB) and 6’ extension cable   

• Keyboard (USB) with a touch pad if 
used with a PVA monitor mount 

• Keyboard extension cable, 6’ 

• Monitor cable, 15’ (Display port or 
DVI)  

• Display port or DVI video support 
(VGA cannot be used) 

• CDROM drive 

• PMInterface Version 1.05, if Portal is 
used 

• Support for Windows 10 LTSB or 
Enterprise (Windows 10 Pro is not 
supported)

NOTE: Portal may not work correctly with systems that do not meet these minimum 
requirements.  

 Galil Controller Requirements 

• Galil controller, DMC 4000/4200 with firmware revision 
D400s08n/DMC4200s05h or newer. Controllers must be purchased from 
PVA. 

o A DMC2000 controller may be used, but the software may only be 
configured for DMC2000 or Legacy modes. 

 Security Software 

Some security software packages and firewalls can interfere with PVA system 
software. PVA software uses Ethernet ports 23, 60007, and 502 by default. Security 
software and firewalls must be configured to allow traffic on these ports. 
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 Setup and Communication   

Before you operate a tool, workcell, or program a path, it is necessary to understand the 
workcell and the software.  

 Operator Skills 

The operator must have basic computer skills and be familiar with the Windows® 7 (or 
Windows® 10) operating system. 

 Install PathMaster® 

NOTE: Make sure that the Windows® User Account Control (UAC) is disabled and the user 
account has Administrator rights before you install PathMaster®.  

1. Insert the CD into the CD drive.  

2. Run ‘PathMaster_Install.exe’ on the CD drive and follow the instructions shown. 

NOTE: If the user does not have administrator rights or if UAC is not disabled, the following 
prompts will be shown. 

 
Figure 1: PathMaster® Installation Administrator Privileges Window 

 
Figure 2: PathMaster® Installation UAC Window 

NOTE: Install the software in its default directory (c:\Program Files\PVA for 32 bit systems, 
c:\Program Files (x86)\PVA for 64 bit systems).  
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Software Startup 

If you receive a warning at startup, please contact PVA. It is possible that the main program 
needs to be updated. If you select “OK” and continue to use the software, some of the 
features may not work.  

 

Figure 3: Example Startup Validation Warning 

 Upgrade Procedure 

PathMaster upgrades are available free of charge, however, to upgrade the software, 
hardware upgrades may be necessary. For a successful upgrade, you must have the 
requirements shown in Section 1.5. Also, it may be necessary for workcells with some 
custom options to have additional edits to work correctly. Please contact PVA’s Customer 
Service Department for information on upgrading your PathMaster software.   

 Multi-Machine Support  

In PathMaster® version 4.3, multi machine support has been deprecated, but backward 
compatibility is maintained.  

When a database is imported in PathMaster® 4.3, the database is checked to see if it is pre-4.2. 
If the database is pre-4.2, PathMaster® checks to see if the database has multiple machines in 
it. If there are multiple machines in the database, the database will be split into multiple 
databases (.bck files) with the data for a single machine in a single database. The new database 
filenames will be the machine name (<MachineName>.bck) and are stored in the 
\PathMaster\DB\Machines folder. When the database split is complete, PathMaster® will load 
the database with the same machine name as the last loaded database. If that machine name 
was not present in the multi-machine database, PathMaster® will load the default machine 
(Default.bck). Every database has a default machine. Any of the new database files (single 
machine databases) can be loaded at any time. Use the machine name to access data from 
each machine in the old database. 
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 Computer and Workcell Communication 

The workcell communicates with the PC through RS-232 or Ethernet. All PVA Portal 
systems communicate through Ethernet. Standalone systems communicate through RS-
232 but Ethernet can be used if the workcell has a Galil DMC2200, DMC4000, or DMC4200 
series motion controller. 

WARNING! The computer must be at the same ground potential as the workcell. 

 Ethernet Communication 

The PC can communicate with the workcell over Ethernet directly, with an Ethernet cross-
over cable, or through a switch (Galil Series DMC2000, DMC4000, DMC4200 required.) The 
Galil controller must remain on a localized subnet that does not see traffic from external 
networks or devices. The only devices that can be on the Galil subnet are the PC and 
remote I/O controllers. Connect all other devices through a separate NIC on the PC. 

Switch  Position Description 

MRST OFF Master Reset Switch 

10B OFF Ethernet Connection Speed 

Ethernet OFF Unsolicited MG’s (Default)  
Table 1: DMC-2200 Dip Switch Settings for Ethernet 

 
Device Address Subnet Mask 

Computer 100.100.100.100 255.255.255.0 

Galil 
Controller 

100.100.100.101 Default 

Remote I/O 100.100.100.102 Default 
Table 2: Typical Ethernet Addressing 
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 Save Settings and Database Folders  

Before the Program Offsets can be applied, a backup of the machine database is created. 
The backup file will save with the date and time. Where the file is saved depends on the 
operation. Refer to the Database Folders chart below for details. When the offsets are 
applied, the database is saved and programs are exported to a DMC format for use with 
PartManager (this is the equivalent of Save For Part Manager option in PathMaster®, 
version 4.1). 

NOTE: Some auto backup and save features can be changed in the PathMaster.ini. Contact 
PVA for details. 

Table 3: Database Folders 

Folder Description 

\PathMaster\DB Active System Database 
\PathMaster\DB\Daily Daily Auto Backups  

• Created once per day on program launch 
• File name AB_<Date>_<Time>.bck 

\PathMaster\DB\Machines Machine Backups 
• Created on import of machine database 
• File name <Machine name>.bck 
• Multiple Backups are created if Multi Machine 

database is imported 

\PathMaster\DB\NeedleCalibration Needle Calibration Backups 
• Created prior to running needle calibration 
• File Name <Date>_<Time>_TOOL_<TL_ID>.bck 
• If multiple tools, file name will contain multiple 

Tool IDs. 
\PathMaster\DB\ToolOffset Tool Offset Backup 

• Created prior to Tool Offset Setup or Tool 
Change function 

• File Name <Date>_<Time>_TOOL_<TL_ID>.bck 

\PathMaster\DB\WorkspaceReference WorkSpace Reference Backup 
• Created prior to Teaching a Workspace 

Reference 
• File Name <Date>_<Time>.bck 

\PathMaster\DB\Transfer Machine Transfer Backup 
• Created prior to Export -> Machine -> Transfers 
• Filename <Date>_<Time>.tfr 
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 Calibration Plate 

Every system should have a recognizable workspace reference position. Standard systems, 
with conveyors or flex fixtures, use a calibration plate (see below). Custom systems and 
systems with non-standard part fixtures will have a defined workspace reference position, 
but may or may not use the standard calibration plate.  

• To use the standard calibration plate, put the plate on the conveyor or flex fixture so 
it is against the fixed rail and the hard stop or board stop.  

• The purpose of the calibration plate, as it relates to PathMaster® 4.2 and 4.3, is to 
define a consistent workspace reference position. This is very important to the 
efficacy of machine transportability. 

 
Figure 4: Calibration Plate 

 Path Program Planning Tips  

• Look at the workpiece to be programmed and find a place to start the path. 

• Plan the path program on paper with a diagram or plotted points.  

• Select the tool (dispense valve, spray valve, jet) for each path. 

NOTE: The first point and direction may not be best and it may be necessary to program 
the path again. 

• Include the active tool operations for each path, ex: Rotate A/B, Tool Up/Down. 

• Put the workpiece in the workcell in a repeatable location and make sure it is parallel 
with the gantry. 

• Insert comments into the program for future editing or other users. Comments are 
shown in red text. 

NOTE: If a stop or dwell must be added at one of the points after a path is completed, the 
path must be broken into two paths or be programmed again. 

 



 
Machine Operation Manual 

 

Revision L / February 2020 Page 21 of 200 

 

 Tool Commands in Programs 

Pneumatic positions (tool up, tool down, rotary selection, etc.) are not automatically 
programmed by PathMaster® and there is no communication between the workcell and 
PathMaster® related to the active tool and its pneumatic position. The operator must 
select the correct tool in PathMaster® and put the necessary pneumatic commands in the 
program. The pneumatics can be operated from the Tools Tab in Portal, or from the OIT 
Interface on the workcell in Manual mode. It is important these commands are in the 
correct locations. In general, follow these rules: 

• Move the X and Y (and W) axes into position before a tool slide or tool rotary is 
actuated.  

• Actuate a tool slide before a tool rotary, if necessary. Make sure there is nothing in 
the motion radius of the tool rotary. 

• Program each segment with the related tool slide in the down position. 

• Add tool slide down and tool rotary B commands into the path program, before any 
segment(s) where the tool is used. 

• Move the gantry to a save Z-height before returning a tool to rotary A position, then 
actuate the tool slide. Input tool rotary A and tool slide up commands into the path 
program when finished with the tool. 

• To change the tool being used safely, include a non-dispense move on the Z-axis to 
0, so there is room for the new tool to lower (refer to Section 2.10).  

 Inter-Path Movement 

After a path is complete, the workcell returns to the ‘standby’ position taught in Setup 
mode. It is necessary to plan out a path programs to make sure there are no obstructions 
between paths. To avoid any potential crashes, program a ‘Z only’ move, with the Z-axis 
target set to 0. The operator must make sure all path programs are safe to run on the 
workcell and dispense surface. 
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 Overview   

 

Figure 5: PathMaster® Window 

If PathMaster® is opened while Portal is in use, the PathMaster® window will open as an 
attached split screen below the Portal window, which will hide the Title Bar. 

 Upper Status Bar 

The upper status bar displays the active machine configuration, current project file and 
current path program, which can be changed with the Program drop-down menu.  

 
Figure 6: Upper Status Bar 

 Lower Status Bar 

The lower status bar shows the current status of the workcell. The communication status 
between the PC and the workcell is shown in the “Connected” display. The “Manual” display 
shows if the workcell is in Manual mode. The “Error” display shows if the workcell is in a 
state of error. The Units field gives the measurement system used when programming 
paths, and can be changed in the Setup section of PathMaster®. 

 
Figure 7: Lower Status Bar 

NOTE: In order to teach path programs online, PathMaster® must be connected to a 
workcell that is in Manual mode, and not in a state of error.  
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 Programming Functions 

The programming toolbar shows the most frequently used programming functions. 
Functions that are green or outlined in green have the ability to reference surfaces. 
Functions that are red do not. With the exception of Polyline, Functions can only reference 
one surface. The toolbar you see depends on the workcell controller. The toolbar shown is 
for a DMC4000 or newer controller.  

 

Figure 8: Programming Toolbar 

Programming functions are used to create path segments, which make up a path program. 
PathMaster® contains a variety of useful programming functions which can be used to 
create 2 dimensional and 3 dimensional paths. The most common functions are on the 
toolbar, other functions can be accessed from the Teach menu.  

 
Figure 9: Explanation of Functions 

Comment – Add comments into the program. 

DMC – Teach a DMC command line in the program. 

Plugin Select – Select a plugin from a preset list of options. 

Dwell – Teach a delay in the program for a set period of time. 

Move – Teach a move to a specific location.  

 2D Path – Teach a 2D path segment and program tool operation. 

3D Path – Teach a 3D path segment and program tool operation. 

Polyline – Teach 2D or 3D path segments and program tool operations that can make 
use of Height Profiling, if applicable. 

Arc – Teach an arc path segment and program tool operation. 
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Circle – Teach a circular path segment and program tool operation. 

Tool – Add a tool function (up/down, rotary, etc.). 

Dot – Dispense at a defined point for a length of time and program tool operation. 

Dot Array – Define a series of dots based on two adjacent points along with X and Y 
pitch. 

Area – Teach a path segment that covers a rectangular area. 

FastMask – Teach a FastMask™ path segment (specify keep out areas). 

Rectangular Spiral – Teach a rectangular spiral segment to cover an area. 

Circular Spiral – Teach a circular spiral segment to cover an area. 

Fiducial – Teach a fiducial A or B command in the path program. The Teach Tool 
(Camera) box must be selected in Setup->Machine Parameters to see this function.  

Surface Height – Teach a surface height command in the path program. The surface 
height reading is used to calculate the Profile Z Height for Run tools used during Polylines. 

Camera Height – Moves the Z axis to the set camera height from the Machine 
Parameters. In the Utilities menu, select “View Camera Tools” to see this function.  

Tool State Selector –Open the Tool State Selector menu to select an 
option. This will move the selected tool to the correct programmed position. This is only 
shown if the Teach Tool box is selected under the Tools section in the Machine Parameters 
Window and PathMaster® is setup for a 4-axis machine. 

FastPath – Open the FastPath™ window for offline programming. The Teach Tool 
(Camera) box must be selected in Setup->Machine Parameters to see this function.  

Theta- Move the selected tool to the calibrated W-axis position (theta). The Theta 
button in all command forms and in the Main Grid now shows an indicator color 

• Yellow means the Theta axis is not at the proper coordinate for the selected Teach 
Tool 

• Green means the Theta axis is at the proper coordinate +- the value in the 
ThetaDeadband string of Pathmaster.ini 

Tool Change- Correct the position of a tool and apply offsets. 

Tool Calibration –Used to change tool offsets and set the profile calibration. 
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 Legacy / DMC2000 Tool Operations 

The controller can be selected in setup mode. When the controller is set as Legacy or a 
2000 series controller, polyline and surface height commands are not available. 

 
Figure 10: Legacy Mode, DMC2000 Toolbar 

 Polyline3D – Teach a path segment with 3D lines and arc commands. 

 PolyLine – Teach a path segment with of 2D, circle, and arc path segments. 

 Run Fiducials / Surfaces / Selection / Sequence 

 

Figure 11: Run Commands 

 Run Fiducials – Plays back any fiducials at the top of the path program and enters 
“corrected” teaching space. See Section 9.4 for more details. 

 Run Surfaces – Plays back any taught surface height commands and enumerates the 
surfaces to be used in and polylines taught after these surfaces.  

NOTE: Subroutines cannot access Surfaces outside of the subroutine, and any Surfaces in a 
subroutine are localized to that subroutine and are inaccessible outside of it. 

 Run Selection – Plays back the selected line(s) of path program. 
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Figure 12: Run Fiducials / Surfaces Status Colors 

 

Run Sequence – Plays the entire path program. 

The highlighted color for Run Fiducials and Run Surfaces will change based on certain 
conditions. The buttons for Fiducials and Surfaces will be yellow if the related command is 
in the current path program but the command has not been run. This refers to teaching in 
“Corrected Space” for Fiducials, and Surface Order Enumeration for Surfaces. The playback 
button for Fiducials will be green when Fiducials have been run for the selected Path 
Program. The playback button for Surfaces will be green when Surfaces have been run and 
correctly enumerated.  

NOTE: If a Fiducial is present in the path program and has not been run, the user cannot 
run, teach, or edit surface commands. 
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Figure 13:Run Selection / Sequence Status Colors 

Once any multiple-line selection is made by the user, the Run Selection / Sequence 
buttons will change color based on several factors. If the selection is cannot be played, the 
button will be red. This shows that the enumeration for surface heights will not be correct 
at the time of playback. If the selection can be played but will skip some surface height 
commands in order to preserve the Surface Height enumeration, the selection will be 
highlighted yellow. If a valid selection is made that can be played in full, the play button will 
be highlighted green. 
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 PathMaster® Database                                                                                                                                                                                                                                                 

PathMaster® uses a flexible database structure to store all parameter and program 
information and must be backed up correctly. The database can be backed up and 
restored. The full database must be manually backed up before and after any changes are 
made to projects or programs. PVA is not responsible for any lost data or production time 
because of incorrect database backup procedures.  

 Automatic Backup 

PathMaster® will do an automatic backup of the full database the first time it is opened 
each day. PathMaster® uses a rolling ten-day automatic backup scheme. A backup file will 
be stored for the last ten days that PathMaster® was used.  

All automatic backups are stored in the Db\Daily sub folder of the PathMaster® application 
folder. The default location of these files is “C:\Program Files\PVA\Pathmaster\DB\Daily”. 

 Manual Backup 

A manual database backup should be part of the programming procedure.  

1. To do a manual database backup, select the File -> Database -> Backup Option from 
the main menu.  

2. Save the project if prompted to do so.  

3. Select the “Backup” button when the Backup Files window opens.  

 
Figure 14: Backup Files 

4. The Save As dialog box opens. Select a location and a filename for the backup file 
(the backup will only be 1 file). The backup file extension will be ‘.bck’.  

5. Select the “Save” button. The PathMaster® database backup is complete. 
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 Modify Database Location, Save the Database on a Network 

1. Open the BDE Administrator, usually in C:\Program Files(X86)\Common 
Files\Borland Shared\BDE\bdeAdmin.exe. 

2. Select pvadb from Databases. 

 
Figure 15: BDE Administrator 

3. Change the Path so that the Database is saved as necessary.  

 
Figure 16: BDE Administrator Select Directory 

4. Select “OK” when finished or select “Cancel” to exit and not save changes or “Help” 
for additional information. 
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 Database Restoration 

To restore the PathMaster® database: 

1. Select the File -> Database -> Restore option from the main menu.  

2. You can restore a *.bck (standard backup) or *.abck (automatic backup) file with this 
option. 

WARNING! A restore PathMaster® database will completely overwrite all data prior to the 
restore. Do not restore partial data with a database restore procedure. 

3. When the file dialog box opens, select the location and file you wish to restore.  

4. Select the “Open” button.  

5. When the “Restore Successful” message displays, select the “OK” button.  

6. Restart PathMaster®. 

 Restoring a database from a PathMaster® 2.3, 3.0 and 4.0 

1. Follow the steps outlined above. Upon restart, you will be prompted indicating that 
the database has been upgraded.  

2. Use the above instructions to restore the database. 

 Restoring a database from prior to PathMaster® 2.3 

It is not possible to restore a database to PathMaster® 4.1 from versions prior to 
PathMaster® 2.3. Any database from a version of PathMaster® before 2.3 does not meet the 
minimum requirements for the restore. Contact PVA if a restore is necessary. 

 Path Programs 

A path program is a collection of individual path segments that make up a dispense 
program. Path programs are made up of any combination of programming functions. Each 
path program can have a unique name of 12 characters or less. The path program name is 
shown on the operator interface while the path runs. 

 Project Files                                                                                                                                                                                                                                                                                 

PathMaster® project files can contain up to 30 individual path programs. A downloaded 
project file has all 30 storage areas, even if some are empty. Empty areas will do nothing if 
selected to run. 
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 Save for Part Manager 

When you select Save or Save As, the current project is saved and exported to a folder 
hierarchy on the hard drive. The default location for the folder is in the ‘PathMaster.ini’ file. 
PathMaster® can be configured to prompt the user for the folder location. 

Example Save (for part manager) folder hierarchy:  Project name: MyProject 

• Select File -> Save or File-> Save As 

A folder called MyProject (Project name) is created in the default project file output 
location (C:\Program Files\PVA\PathMaster\Projects). In the MyProjects Folder, 30 
individual files are created, one for each program in the project. The files names of the 30 
program match the program name. If the program name contains characters that are not 
allowed in file names, the character is replaced with the character ‘@’. 

 

Figure 17: Save for Part Manager 

 INI Settings for ‘Save For Part Manager’ 

• Default folder location for Save For Part Manager: ProjectFileOutput=C:\Program 
Files\PVA\PathMaster\Projects 

• Set if the default location is used or if the user is prompted to select a location: 
UseDefaultProjectFileOutput=1 

CAUTION: The Path specified in the ‘[General]’ section of the ‘PathMaster.ini’ file with the 
‘ProjectFileOutput’ key is for PathMaster® use only. This folder is an extension of the 
PathMaster® database, for use with PVAPortal’s dependency, PartManager. Any external 
data written to this folder or its children will be overwritten by PathMaster®! 
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 Machine Program Transport 

PathMaster 4.4 can import data from previous versions of PathMaster, but previous 
versions of PathMaster cannot import data from PathMaster 4.4 or newer. This includes all 
types of data imports (Machine, Program, Project, Subroutine). 

WARNING: Tool Offsets and Workspace Reference positions must be correctly configured 
on both the source and destination machine before a Machine Program Transport is done. 
Refer to sections 6.4.7 and 6.6.5 for more information. 

A machine program transport requires a transfer file (.tfr) from the source machine to be  
imported onto the destination machine. 

The Transfer file contains program data, Workspace Reference Position and the Z 
component of Tool Offsets. The Import Machine Transfer function compares the source 
machine Workspace Reference position (X,Y only) to the destination machine Workspace 
Reference position (X,Y) and finds an appropriate global offset for the destination machine 
programs. The Z component of tool offsets are also compared to find an appropriate Z 
offset for each tool on the destination machine. 

NOTE: When the configuration of systems is planned for Machine Program Transport, the 
systems should be matched mechanically as much as possible. The Tool ID’s should also be 
the same from one system to another. For example, if a dispense valve on the source 
machine is the first virtual tool (TL_ID 1) and a spray valve is the second virtual tool (TL_ID 
2), the destination machine must have the same tool relationship (1st tool = TL_ID 1, 2nd 
tool = TL_ID 2), etc. 
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 Exporting a Transfer File 

1. To export a Transfer File, select File -> Export -> Machine -> Transfer from the main 
menu.  

 
Figure 18: Export Machine Transfer 

2. A prompt will ask for a file name and destination. Name the file. The Transfer File will 
have a ‘.tfr’ extension. The transfer file can be imported onto a destination machine. 

 Importing a Transfer File 

1. To import a Transfer File, select File -> Import -> Machine -> Transfer from the main 
menu.  

 

Figure 19: Import Machine Transfer 

2. A prompt will ask for a transfer file name. Select the necessary file. The transfer file 
will have a ‘.tfr’ extension. 
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 Machine Transport Errors 

When a machine transfer file is exported, PathMaster® makes sure that all tools that are 
referenced have an associated virtual tool configured. When a machine transfer file is 
imported, PathMaster® makes sure that all tools referenced by a path in the transfer file 
are configured on the destination machine, and that the destination machine has the same 
name as the source machine. If there is a machine name or tool configuration mismatch, 
PathMaster® will show an error and the import or export will be canceled, and a transfer 
error detail file (‘TransferErrorDetails.txt’) will be written to the \PathMaster\Logs folder. 

The transfer error detail file will outline the machine, project, program #, line # and tool that 
had the issue. Having more tools configured than are used is allowed, but if a tool is 
referenced in the source machine, it must exist on the destination machine.  

 
Figure 20: Example Export Error 

 

Figure 21: Example Import Error 

Example TransferErrorDetail.txt 

Project,Program,Line#,ToolID 
DEFAULT,PROGRAM1,7,3 
FASTPATH_SAMPLE,PROGRAM1,25,3 
FASTPATH_SAMPLE,PROGRAM1,28,3 
FASTPATH_SAMPLE,PROGRAM1,31,3 
FASTPATH_SAMPLE,PROGRAM1,34,3 
FASTPATH_SAMPLE,PROGRAM1,37,3 
FASTPATH_SAMPLE,PROGRAM1,40,3 

  



 
Machine Operation Manual 

 

Revision L / February 2020 Page 35 of 200 

 

 Operation 

 Start PathMaster                                                                                           

It is necessary to configure PathMaster® to run correctly with the workcell when it is 
initially setup.  

1. Double-click on the PathMaster® icon to start PathMaster®, or to start 
PathMaster® from Portal, select Manual mode. Select the PathMaster® tab and 
then select the PathMaster® button. 

 
Figure 22: PathMaster® Opened through Portal 

2.  The Select Project dialog box will be shown.  

3. Select Create a New Project. 
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Figure 23: Select Project Window 

4. Select “OK”.  

 Project Selection 

You must select the correct project before you start to program. You can open an existing 
project or create a new project. The Select Project window is shown at startup, when 
PathMaster® changes the current machine setting, or if you open a different project. 

1. Select the correct choice from the Select Project window. 

2. Select the “OK” button. 

3. Highlight the correct project.  

4. Select the “OK” button to open the project. 

 
Figure 24: Select a Project 

5. Select the “Cancel” button to exit and make no changes. 
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 Machine Parameters 

You must setup the Machine Parameters the first time you use PathMaster®. The Machine 
Parameter window is used to set software and hardware properties. The settings in the 
Machine Parameter window apply only to the current machine profile. The current machine 
profile is shown in the Upper Status Bar of the main PathMaster® window. 

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

 

Figure 25: Setup Machine Parameters 

NOTE: If you attempt to make changes that require a MAIN program change, a window will 
be shown to confirm the changes. 

 

Figure 26: MAIN Program Change Conformation 

2. To exit the Machine Parameters window, select “Save & Close” to save changes and 
exit or “Cancel” to exit and not save changes. The changes are not applied until you 
select “Save & Close”.  
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 Dispensing Parameters 

The dispensing parameters are the default parameters for all coordinated path motion. 
These parameters can be modified in each programming function for each path segment. 
These settings are found in the Machine Parameters window.  

 
Figure 27: Dispensing Parameters 

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

2. Set the Path Acceleration and the Path Deceleration speed. This will be the default 
acceleration and deceleration for all coordinated motion. 

  



 
Machine Operation Manual 

 

Revision L / February 2020 Page 39 of 200 

 

 Move Parameters 

The move parameters are the default parameters for all independent path motion for each 
axis of motion that does not include any dispensing. Select the necessary axis from the 
tabs available to view and change the move parameters. These settings are in the Machine 
Parameters window. 

 
Figure 28: Move Parameters 

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

2. Select the necessary Axis Tab (X, Y, Z, W). 

3. Set the Move Speed. This is the default speed for all independent path motion. 

4. Set the Move Acceleration and Move Deceleration in speed. This is the default 
acceleration and deceleration for all independent path motion. 

5. Set the Max Speed. This is the greatest speed for an independent path motion. 
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 Units and Machine Type 

These settings are found in the Machine Parameters window. 

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

2. Select the necessary measurement system from those shown (counts, inches, or 
millimeters).  

 
Figure 29: Units and Machine Type 

3. Select the necessary Axis from the drop-down menu to configure PathMaster® for 
a two, three, or four axis gantry.  

WARNING: If you change axis after a path has been created it may have unintended 
consequences. Tool offsets must be updated as necessary. If you remove an axis, the 
offset of that Axis will be permanently deleted. 

4. Select the Stepper Motors box if your workcell has stepper motors instead of servo 
motors. Refer to Figure 29. 
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 Motion Options 

PathMaster® can have up to 14 devices configured. All Devices are physical tools in the 
system. Devices are used to relate a Virtual Tool to a physical tool. These settings are found 
in the Machine Parameters window. 

• Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

 
Figure 30: Changes in Options When the Teach Tool Box is Selected 

• Some options shown in this manual are only available when the Teach Tool box is selected. 

NOTE: You must a use a local copy of the software for the teach tool to work correctly. 
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 Teach Tool 

When the Teach Tool function in PathMaster® is enabled, the first virtual tool (Tool ID 0) 
will be the teach tool by default and will be related to the first Device (Device ID 0). If a 
workcell does not have a teach tool, the first tool spot will be reserved. If a teach tool is 
added on the workcell later, the reserved first tool will become the teach tool. 

Also, when the Teach Tool is enabled, PathMaster® shows the options for the teach tool. 
The box should be checked if there is a teach tool installed.  

 

• When the Teach Tool box is selected, Pathmaster® shows the options for the teach 
tool. The box should be checked if there is a teach tool installed. 

 
Figure 31: Changes in Options When the Teach Tool Box is Selected 

Some options shown in this manual are only available when the Teach Tool box is selected. 

 Camera Z Position  

The value in the Camera Z Position box is the Z height used when the “Move to Camera Height” 
function in the toolbar is selected. The machine must be in manual mode and this height should be 
where the camera is in focus with the product to be observed. 

 Enable Global Offset Variables 

If you select this feature, offset variables can be used in a workcell so that the same 
program can be used in more than one workcell. The main program of the machine must be 
programmed for this feature. If the main program has not been changed, the workcell will 
show a Command Error (refer to the Troubleshooting manual). 
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 Enable Pause 

If you select this feature a program can be stopped and then restarted mid-cycle in 
automatic production. The main program of the machine must be programmed for this 
feature. If the main program has not been changed, the workcell will show a Command 
Error (refer to the Troubleshooting manual). 

 
Figure 32: Machine Parameters, Tools Section Options 

 Tool Routine Configuration 

The Tool Routine Configuration drop down menu will come set from the factory or will be 
selected as “Legacy” if PathMaster has been updated. If you change this setting, Main 
program changes will be necessary or you will have program errors. 

 
Figure 33: Tool Routine Configuration 

 Needle Calibration 

The Needle Calibration Reference Position defines where the needle calibration unit is 
physically located in the system. The needle calibration setup is a two-part setup. First, the 
needle calibration reference position is set, then, the needle calibration sensor locate 
sequence runs. 

WARNING: The tool offsets must be configured before the needle calibration is set up. If 
Tool Offsets are not configured correctly when the Sensor Locate Sequence is run, the 
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1. Select the “Configure” button to set the Needle Calibration Reference position and 
run the sequence. 

 
Figure 34: Needle Calibration 

2. To set the Needle Calibration Reference Position, line the teach tool up with the 
cross hair on the needle calibration unit and select the “Teach” button.  
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Figure 35: Needle Calibration Setup Window 

3. Click the “Move To Point” button to move to the last programmed needle calibration 
reference position. 

4. Next, push “CTRL + S” on the keyboard to run the needle calibration Sensor Locate 
sequence. It is not necessary to run this every time a needle calibration reference is 
set, but it must be done initially and if the sensor is damaged or replaced. This 
sequence establishes the X, Y, Z relationship of each sensor as it relates to the 
crosshair on the needle calibration unit. The tool offsets and needle calibration 
reference position are combined with relative sensor locations to find each tool in 
the needle calibration unit. 

5. Push “Ctrl + S” on the keyboard to run needle calibration Sensor Locate sequence. 

6. The first time the sensor locate sequence runs, the user will be shown a list of tools. 
Select the tool that will be used for the sensor locate sequence. The selection is 
saved and the prompt will not be shown again.  

 

Figure 36: Tool Selection 
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NOTE: For a tool to show up in the tool selection list, the “Needle Calibration” checkbox 
needs to be checked in the Tool Configuration window, which is hidden if the tool type is 
either Teach Tool or Profile Tool. 

 

Figure 37: Use Needle Calibration Checkbox 

NOTE: It is not necessary to run the Sensor Locate Sequence again unless the position of a 
sensor relative to the needle calibration cross hair changes, such as if the needle 
calibration circuit board is replaced or is damaged. 

7. When the needle calibration reference position has been taught, select the “Done” 
button, or select “Cancel” to exit and not save changes. 

 Profile Calibration 

Height profiling (new in PathMaster 4.3) uses two height-reading devices, with the polyline 
programming tool, to adjust the Z-height of dispenses on parts based on surface readings 
done at the start of the path program. One height reading device is mounted inside the 
machine at a fixed location, facing up, called the Profile Base, the second is mounted on 
the gantry and is either at a fixed Z-height or moves along the Z-axis, and is called the 
Profile Tool. 



 
Machine Operation Manual 

 

Revision L / February 2020 Page 46 of 200 

 

WARNING: The tool offsets must be configured before Profile Calibration is set up. If Tool 
Offsets are not configured correctly, the system could be damaged when the Profile 
Plunger Locate Sequence is run.     

• To setup height profiling, it is necessary that all tool offsets are correctly set up, 
that Needle Calibration Setup is complete (if applicable), and that a tool is set up 
with the tool type of “Profile Tool” in Machine Parameters. 

• When Setting up a Profile Tool Type, a second selection box is shown for the Profile 
Type: Non-Contact or Contact. A selection must be made for correct operation of 
the Profile Tool. 

 
Figure 38: Profile Tool Type and Profile Type Selection 

1. After the setup is complete, click “Configure” underneath Height Profiling in the 
Machine Parameters window to open Profile Calibration Setup. 

 
Figure 39: Height Profiling 

2. To set the Profile XY Reference Position, line the teach tool up with a point on the 
Profile Base and select the “Teach” button. Click the “Move To Point” button to 
move to the last programmed Profile XY Reference position. 
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Figure 40: Profile Calibration Setup 

3. Next, run the Profile Plunger Locate Sequence by pressing CTRL + S on the 
keyboard. It is not necessary to run this every time a Profile XY Reference position is 
set, but it must be done during initial setup, if the Profile Base is damaged or 
replaced, or if the Profile Tool is damaged or replaced. The Profile Plunger Locate 
sequence uses the Tooling Offset between the Teach and Profile Tools to read the 
Profile Base Plunger to determine a common profile surface for all tools, called the 
Profile Z Reference. 

4. When the Profile XY reference position has been taught, and the Profile Z Reference 
is established, select the “Done” button, or select “Cancel” to exit and not save 
changes. 
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 Workspace Reference  

Workspace reference is a global reference position used to help make a machine program 
transport or a global offset to the local system. 

To teach a workspace reference point, on a typical system, put the machine calibration 
plate against the board stops and put the teach tool at the cross hair on the machine 
calibration plate. The workspace reference point must reference the part workspace so 
that if the part fixture changes, due to board stop location, etc., the workspace reference 
point moves with it. 

 
Figure 41: Workspace Reference  

1. Select the Workspace Reference “Configure” button.  

 
Figure 42: Workspace Reference Window 

2. Click the “Move To Point” button to move to the workspace reference position. 

3. If the Move to Point button is not in the correct location, use the teach tool to move 
to the necessary workspace reference position. Click the “Teach” button to teach 
the workspace reference position. 

4. The Update Reference Position Only checkbox is checked by default. This will 
update the workspace reference position but not apply program offsets (The 
difference between the original workspace reference and the new workspace 
reference). Uncheck this box to apply global offsets to all programs.  
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5. Select the Z Position from the drop-down menu. The Z component of the 
workspace reference can be chosen from the current position, a position that is 
typed in, or from the tool position of the tool Z offset. 

 
Figure 43: Select the Z Position  

6. Select the Do not apply offset to Z axis checkbox, if the Z offset should not be 
included. 

7. When the settings have been set, select the “Done” button, or select “Cancel” to 
exit and not save changes. 

NOTE: The Teach Tool option must be enabled and the machine must be in Manual mode to 
teach the workspace reference position. 
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 Devices 

PathMaster® can have up to 15 devices configured if the teach tool is enabled. All Devices 
are physical tools in the system. Devices are used to relate a Virtual Tool to a physical tool. 
These settings are found in the Machine Parameters window.  

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

2. To configure the devices in the system, click ‘Devices’ in the Virtual Tools section of 
Machine Parameters. 

3. From here you can name all the Devices in the system. Any name that is left blank 
will be unavailable to use to teach paths and during playback. 

With the Teach Tool function in PathMaster, the first device will be the teach tool (device 0) 
by default. If a workcell does not have a teach tool, the first tool spot will be reserved. If a 
teach tool is added on the workcell later, the reserved first tool will become the teach tool 
and prevent many programming changes. 

 
Figure 44: Tool Name and Configuration 

NOTE: Devices must be listed in sequential order. For example, if Device 5 is left blank, all 
following Devices will be unavailable for playback and teaching. If a tool is deleted it will not 
be available.  
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 Virtual Tools 

PathMaster® can have an unlimited number of virtual tools configured. All virtual tools are 
related to a physical device in the system. A device can be saved with specific settings as 
several different virtual tools.  

For example, in a 4-axis system, Tool 1 can be device A with a theta rotation of 0°. Tool 2 
can be device A with a theta rotation of 90°. The same device is used for Tool 1 and 2 but 
the valve settings are different.  

The different theta positions of the virtual tools changes how the physical device relates to 
the teach tool. The difference in position relationship is called the tool offset. Refer to 
Section 6.6.5 for more information. 
  
If the teach tool is enabled, you must create Virtual Tool 0 first for Device 0 before you can 
create additional virtual tools. 
 

 Sort 

With the Sort radio buttons, you can arrange how you view the Virtual Tools in the system. 
You can sort the virtual tools by Tool ID, Device ID, Name, or Description. 

 

Figure 45: Sort Options 

• Select the necessary label to sort the virtual tools. 
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 Add a Tool 

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window.  

2. To add a new virtual tool, click the “Add” button in the Virtual Tools section of 
Machine Parameters. 

 

Figure 46: Add a Virtual Tool 

3. The Tool Configuration menu will open; refer to Section 6.6.4 for more information 
about how to correctly configure a virtual tool. 
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 Delete a Tool 

Select Setup->Machine Parameters from the Main menu to open the Machine Parameters 
window. 

WARNING: If a Virtual Tool was used in a path before it is deleted you will have to update 
that path with a different virtual tool. If you play a path that uses a deleted virtual tool 
there may be unintended consequences. 

1. To delete a virtual tool, select the tool in the Virtual Tools section of Machine 
Parameters window.  

2. Click the “Delete” button.  

 
Figure 47: Select Virtual Tool and Delete 

3. A warning window will be shown, click “Yes”. 

 
Figure 48: Delete Tool Window 

A deleted tool ID will go to a reserved state. You will have the option to use the deleted tool 
ID when you create a new virtual tool.  
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 Tool Configuration 

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

2. To configure an existing virtual tool, highlight a virtual tool and click the “Configure” 
button in the Virtual Tools section of Machine Parameters. Or, double-click an 
existing tool to open the Tool Configuration window. 

 
Figure 49: Tool Configuration 

3. Set the Tool ID from the dropdown number list. This can only be changed when you 
add a new virtual tool. 

4. Set the Device the virtual tool uses with the dropdown menu. The device is the 
physical tool that the virtual tool uses with specific programmed settings. 

5. Set the Type of virtual tool with the dropdown menu. This is the type of device that 
will be used during operation. 

6. Select the Z-Slide box if this tool has a slide installed. 

7. Select the Rotary box if this tool has a rotary installed. 

8. Set the tool On to Wait or Distance and set the time or distance. Wait is the pause 
after the tool turns on but before the path is started. Distance is the length of the 
path traveled before the tool turns on.  
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9. Set the tool Off to Wait or Distance and set the time or distance. Wait is the pause 
after the path is finished and the tool is off but before the tool goes to the next 
point. Distance is the length of the path traveled after the tool is off but before the 
path is done.  

10. Set the default Speed for the virtual tool. 

11. Set the Line Spacing for the distance between runs when an area path or 
rectangular spiral is used.  

12. Set the Display Color for the color used for offline programming features. 

13. Set the default Relative Height. This is the distance from the surface of the product 
to the lowest point of the tool above the product, as taught in the tool offset 
function (offline programming only). 

14. Set the Dot On Dwell and the Dot Off Dwell time. This will be the default tool on and 
tool off time for the Dot function for this virtual tool. 

15. Set the Z-Retract (relative) distance. This will be the default relative Z-retract for 
the Dot function for this virtual tool. 

16. Select “Save” to save your changes and exit. Select “Cancel” to exit and not save 
changes.  

 

Figure 50: Teach Tool Configuration 

NOTE: Some options in Tool Configuration are changed or disabled when a type of “Teach” 
or “Profile” is selected.  
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 Tool Offsets 

NOTE: Tool Offsets are only available if the Teach Tool box is checked.  

Tool offsets define the X, Y, theta relationship (offset) between the teach tool (usually a 
camera) and every other physical tool installed on the workcell. Tool offsets let a teach tool 
be used to program paths in PathMaster® and use a different physical tool to playback the 
path. PathMaster® must measure the offset for each tool relative to the teach tool for this 
to work correctly. In PathMaster®, the tool offsets are defined (setup) with the Tool Offset 
option in the Tool Configuration window. 

When you teach tool offsets, you must put the tool in the correct state before you teach 
the tool position. For example, on a 3-axis system with a dispense valve mounted on a 
pneumatic rotary, put the pneumatic rotary in the necessary state (A or B). On a 4-axis 
system, put the theta axis in the correct position before you teach the tool offset. 

WARNING: If the Teach Tool function is enabled, the Tool Offsets must be set before the 
Workspace Reference, Needle Calibration Reference, or Profile Relative Surface positions 
are set. Tool Offsets also need to be set before a Tool Change, Needle Calibration, Surface 
Height, or a path program is taught. 

 To Teach Tool Offsets 

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

2. Select the virtual tool you want to configure the offset for. Double click on the 
virtual tool or highlight it and select “Configure”. 

NOTE: Set up the teach tool, tool 0, first. Then set up any additional tools.  

3. Select the “Tool Offset” button in the Tool Configuration window.  

NOTE: If you do not have the Teach Tool (Camera) box selected in the Machine Parameters 
window you will not see the “Tool Offset” button. 

 
Figure 51: Tool Offset Button 

NOTE: Tool 0 (the teach tool) has a “Tool Reference” button, not a “Tool Offset” button, and 
the Tool Type is set to ‘Teach’. 
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Figure 52: Teach Tool, Tool Reference 

4. Move the theta axis (4-axis systems only) to the correct position with the Trackball 
or click the “θ” button to move to the last calibrated theta position. 

PathMaster® must measure the offset for each tool relative to the teach tool. It is 
necessary to teach a tool at a reference or fiducial point.  

 
Figure 53: Run Tool Reference Training Window 

5. Move the teach tool above the reference point, which both the teach tool and the 
selected tool can reach. Or, select the “Move to Point” button to move to the teach 
tool reference point, if previously taught. 

6. When the teach tool is above the reference point, select the “Teach” button. Make 
sure Z height and W (optional axis) are correct in the taught position.  

7. Move the run tool to the reference point and select the “Teach” button.  

8. Select the Update Reference Position Only (Do not apply Offsets) checkbox to 
update the reference position only, tool offsets will not be applied. The default is 
unchecked, and tool offsets are applied to all corresponding path segments (all 
programs, all projects).  
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NOTE: If the Update Reference Position Only (Do not apply Offsets) box is unchecked, 
offsets will automatically be applied to any existing paths or programs that use the tool 
that was changed and will be applied to any new paths or all programs created. 

NOTE: When the Teach Tool reference position is updated, Tool Offsets are updated to 
reflect the change in relationship between the Teach Tool and each Run Tool. 

9. When tool offsets have been taught for each tool, select the “Done” button, or 
select “Cancel” to exit and not save changes. 

The distance between the run tool and the teach tool has now been taught. Repeat steps 
2-9 for all other tools. 

NOTE: If the run tool is a valve, you can use a dot of material on a surface and teach the run 
tool over the dot. Refer to Section 6.6.7.  

10. Select the “Save & Close” button to exit and save the changes. 

 Dot Drop Mode 

Dot Drop Mode is used to align the run tool and teach tool when the run tool cannot be 
aligned with the reference point or fiducial because it does not have a protruding tip. It can 
also be used if the operator prefers it.  

1. Select the Dot Drop Mode checkbox to enable this function. When you select the 
check box, the Dispense Position and Run Parameters will be shown in the Offset 
Training window. If you select and save the values for dot drop mode, the settings 
will be saved for future use with this tool.  

 
Figure 54: Dot Drop Mode 
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2. Teach the Dispense Position with the teach button, this is the location the dot will 
be dispensed. The dispense position is stored for this tool.  

3. Set the On Time in seconds. This is how long the tool will operate to dispense the 
dot. 

4. Select “Run” to dispense the dot for the set On Time. 

5. Move the teach tool to the dispensed dot and teach the position. 

6. When the tool offsets have been taught for each tool, select the “Done” button, or 
select “Cancel” to exit and not save changes. 

NOTE: If Dot Drop Mode is enabled for a tool, that tool will reference Dot Drop mode when a 
Tool Change is done. 

NOTE: If a Dispense Position is taught, the Run Tool reference position will be calculated 
automatically and can be used when you exit Dot Drop mode. 

 Tool Change 

A Tool Change adjusts the tool offset and applies a program offset to correct the position 
of a tool. A tool change should be done after a needle is changed, or if a tool installed after 
maintenance has been done. A tool change should be done after any change in the 
physical location of a tool tip. 

NOTE: The teach tool option must be enabled to use the tool change function. 

 

Figure 55: Tool Change Button 

1. Select the Tool Change button on the main tool bar. 

2. Select a tool from the Tool Selection window. 
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Figure 56: Tool Selection Window 

3. Select the “OK” button. 

 

Figure 57: Tool Offset Window 

4. Align the selected tool with the reference position (the same position referenced by 
the Teach Tool). You can use the “Move To Point” button to move to the run tool 
reference position. 

5. Select the “Teach” button to teach the run tool reference position. 

6. Select the “Done” button, or select “Cancel” to exit and not save changes. 

7. If “Use Profile Calibration” is enabled on the current tool, the Tool Calibration for 
changing the Profile Offset will automatically run. 
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 Tool Calibration 

A tool calibration must be done after a needle is changed, if a tool is installed, or after any 
change in the physical location of a tool. The purpose of a tool calibration is twofold: 

• If “Use Needle Calibration” is enabled on a virtual tool’s Tool Configuration, the Tool 
Calibration Function adjusts the tool offset and applies a program offset to correct 
the position of the tool’s tip.  

• If “Use Profile Calibration” is enabled on a virtual tool’s Tool Configuration, the Tool 
Calibration Function adjusts the Profile Offset for the tool. 

NOTE: Enable the teach tool option to use the Tool Calibration function. 

 
Figure 58: Tool Calibration 

WARNING: The tool offsets, the Needle Calibration Sensor Locate Sequence (if applicable) 
AND the Profile Plunger Locate Sequence (if applicable) must be set up before a Tool 
Calibration is done, or the system could be damaged. 

1. Select the Tool Calibration button on the main tool bar. 

2. Select the necessary tool from the Tool Selection window. Multiple, consecutive 
tools can be selected. Use the Sort buttons to sort the tools so the necessary tools 
are listed consecutively. Hold the “Shift” key and click or click and drag to highlight 
the tools to calibrate.  

NOTE: For a tool to show up in the tool selection list, the “Use Needle Calibration” checkbox 
or the “Use Profile Calibration” must be checked in the Tool Configuration window. 

 

Figure 59: Tool Selection Window 
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3. Select the “OK” button. 

 
Figure 60: Calibration Wait Screen 

4. When the Tool Calibration is done, changes are saved and offsets are applied to the 
path programs for the related tool(s), if Needle Calibration was run. 

5. For multi-tool calibration, all applied calibration operations run for each tool, in any 
combination of Needle Calibration and Profile Calibration. Any changes to Tool 
Offsets or Profile Offsets are saved and offsets are applied to tools individually, if 
the calibration was successful.  

6. If any of the selected tools fail, the sequence is stopped. Any tools that were 
completed before the failed tool will have Tool Offsets and/or Profile Offsets 
applied. If a multi-tool calibration fails, move the mouse over the failed message to 
show a pop up with the status of each tool. The popup window must have focus to 
show the popup hint. 

 
Figure 61: Calibration Status Screen 

7. Use the “Cancel” button to stop the sequence. For multi-tool calibration, the current 
tool will finish calibrating and changes will be saved for all of the tools that complete 
calibration before the calibration was canceled. 
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 Auxiliary 

The machine auxiliary feature is used to hardcode custom software options into the 
machine software. This function is programmed by PVA and instructions on how to use it 
are supplied if necessary.  

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

2.  If necessary, select the “Machine Auxiliary” button. 

 
Figure 62: Machine Auxiliary 

3. Make the necessary changes in the Auxiliary Code window. 

 
Figure 63: Auxiliary Code 

4. Select “Save & Close” to keep the changes. 

5. Select “Cancel” to exit and not save changes. 
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 Communications 

This feature is used to configure the RS-232 communication or Ethernet settings between 
the computer and the workcell. PathMaster® uses control handles to store all 
communication settings for a machine. The information in the control handles is stored in 
the Windows® registry. PathMaster® can have multiple control handles configured, but 
only one control handle can be selected at a time. When PathMaster is installed it creates 
controller 1 as an Ethernet controller with an IP address of 100.100.100.101 as a default. 
These settings are found in the Machine Parameters window. 

 
Figure 64: Communications 

The table below has the list of IP Addresses referenced directly by PathMaster® or its 
underlying architecture. 

IP Address Description 
100.100.100.101 Motion Controller 1 (Default) 
100.100.100.102 Motion Controller 2 
100.100.100.103 Motion Controller 3 
100.100.100.104 Motion Controller 4 
100.100.100.105 Motion Controller 5 
100.100.100.106 Motion Controller 6 
100.100.100.110* Remote I/O 

Table 4: PathMaster IP Addresses 

 Change Controller 

Select “Change Controller” to select from any pre-configured controller handles stored in 
the Windows® registry. 

 No Reset Download 

If you select this feature the workcell will not reset when the project is downloaded. The 
DMC Motion Controller must have the latest firmware revision (D220S36N or higher) to use 
this feature. The main program of the machine must be programmed for this feature. If the 
main program has not been changed, the workcell will show a command error. Refer to the 
Troubleshooting document for more information. 

  Saving Machine Parameters 

When all machine parameters have been set, select the “Save & Close” button to save the 
parameters and return to the main PathMaster® window. 
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 Program Details 

 Main Program Modifications 

If it is sometimes necessary to make changes in the main program that runs the workcell. 
You must correctly download the corrected main file to prevent any problems. Use a text 
editor, such as Windows® Notepad or Winpad to open the Main program.  

 Common Main Program Changes 

There are a few sets of points that regularly need to be changed, these include: standby 
position, purge position, solvent cup position, and calibration position. In the main program 
these settings are in the Machine Specific Information section (near the end of the file). An 
example is shown below: 

REM !!!! Machine-Specific Information !!!! 
#IMACH;MT 1,1,1,1 
CE 0,0,0,0;FSTX=20000;SLWX=10000;FSTY=20000;SLWY=10000 
FSTZ=10000;SLWZ=5000;FSTW=10000;SLWW=5000 
KNTOOL=3;A_TOOL[1]="FCS100";R_TOOL[1]=0 
A_TOOL[2]="FC100 ";R_TOOL[2]=1 
A_TOOL[3]="DISPSE";R_TOOL[3]=1 
PT_APG[0]=80000;PT_APG[1]=65000;PT_APG[2]=0;PT_APG[3]=3000 
PT_SOL[0]=80000;PT_SOL[1]=65000;PT_SOL[2]=0;PT_SOL[3]=3000 
PT_CAL[0]=15000;PT_CAL[1]=15000;PT_CAL[2]=500;PT_CAL[3]=2000 
PT_SBY[0]=25000;PT_SBY[1]=25000;PT_SBY[2]=250;PT_SBY[3]=3500 
AP_EN=0;AP_LEN=2000;AP_TIME=30000;PNTO=4000;LT_EN=1;AC_TMR=1 
SLP_TM=30000;SO_EN=0;LLA_EN=0;LLB_EN=0 
#TUNE;AC*=325000;DC*=300000;SP*=120000;VA*=70000;VD*=70000 
BL -4000,-4000,-1000,-1000 
FL 83000,85000,15000,30000;TL*=9.9999 
KD 67.99,82.43,76.09,50.00 
KP 5.66,6.75,8.38,5.00 
KI 0.25,0.19,0.34,0.50;EN 

The following tables display the command variables that it may be necessary to change. 
Table 5 – Coordinate System Locations 

 Axis 
Locations X Y Z W 

Auto Purge Location PT_APG[0] PT_APG[1] PT_APG[2] PT_APG[3
] 

Solvent Cup Location PT_SOL[0] PT_SOL[1] PT_SOL[2] PT_SOL[3] 

Calibration Location PT_CAL[0] PT_CAL[1] PT_CAL[2] PT_CAL[3] 

Standby Location PT_SBY[0] PT_SBY[1] PT_SBY[2] PT_SBY[3] 

When the main program has been changed, download the new program to the controller. 
Use the PathMaster® Download -> Main function. 
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 How to Read a Program 

The PathMaster® program display is arranged in a table format. Use the chart below to 
determine the purpose of the text that appears in each field. 

 
Figure 65: Program Table 

 
COLUMN USE EXAMPLE EXPLANATION 
Command Programmed 

Command 
DOT Dot Program 

LINE(3D) 3D Line 

Position Coordinates 4555,3000,760 Cartesian coordinates for current point 

On Tool or I/O on (1)W.5 Activate tool 1, tool on time of .5 
seconds 

  (2)D300 Activate tool 2, tool on distance of 300 
counts 

  I49 Wait for input 49 to be on 

  O32 Turn on output 32 

Off Tool or I/O off W.75 Deactivate the path’s tool 1, tool off 
time of .75 seconds 

  D500 Deactivate the path’s tool, tool off 
distance of 500 counts 

  I51 Wait for input 51 to be off 

  O35 Turn off output 35 

Speed Path speed 2000 Path speed of 2000 counts per second 

Other Varies according 
to path 

Z=250 Z-axis relative move of 250 counts 
after completing a dot path 

NOTE: A command uses all the lines below it until another command reference appears in 
the Command column. 
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 Playback 

Paths can be played with PathMaster® or downloaded and run on the workcell. 
 To run an individual path 

1. Highlight an individual path from the PathMaster® window. 

2. Select Run ->Selection from the drop-down menu or the right-click menu. 

 To run an entire program 

3. Select Run ->Program from the drop-down menu or the right-click menu. 

4. Before the path runs, the user must select “Wet”, “Dry” or “Virtual Tool 0”. The name 
for the third option will be the name of Virtual Tool 0.  

 
Figure 66: Playback 

“Wet” playback activates the tool(s) and material will dispense. “Dry” playback does not 
activate the tool(s). “Virtual Tool 0” (replaced by the name of “Virtual Tool 0”) will run the 
path with the teach tool at “Virtual Tool 0” Z, as defined in Machine Parameters instead of 
the run tool. 

5. Select “Start” to run the path as selected or “Close” to exit without running the 
path. 
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 Edit Windows 

The operator can change a path segment after it has been created. Double click on the 
path segment to show the edit window. The Coordinates box is shown in the upper left-
hand corner of the edit window. All the programmed coordinates are shown.  

 

Figure 67: Example Edit Window 

Use the options shown as necessary to edit the paths. Not all options will be shown in 
every edit window. 

1. Select Move to Point to move to the point highlighted in the coordinates box. 

2. Select Edit Point to open the point highlighted in the Coordinates box in the edit 
window. 

3. Set the Tool Height to “Use the Current Z Height” or “Use Calibrated Z Height,” or, if 
the function has surfaces, select the Surface from the drop-down menu. If 
necessary, set the Relative Height in millimeters. 

4. Select the Run Tool. 

5. Select (double click) on the necessary tool. 

 
Figure 68: Tool Selection 
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6. Select the Teach Tool. 

7. Select (double click) on the necessary tool. 

8. Set the Path Speed. 

9. Set the Tool On to “Wait” or “Distance” and set the time or distance. 

10. Set the Tool Off to “Wait” or “Distance” and set the time or distance. 

11. Set the Line Spacing. 

12. Select “Done” to save the changes, or “Cancel” to exit and not save changes. 

 Important Reminders 

• To Insert Code – When PathMaster® programming functions are used to insert code, 
the code is inserted above the current highlighted location on the screen. The 
operator must make sure the new path is put in the correct position. 

• To Insert Tool Functions – Commands to move the tools are NOT automatically 
inserted into the path programs. If a tool must change position (up/down, rotary) 
the correct function must be inserted manually with the Tool programming 
function. Refer Section 2.9.  

• To Download Files – The operator must activate the EMERGENCY STOP button when 
downloading files to the controller. 
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 Workcell Interaction 
For PathMaster® to operate correctly it must work with the workcell. The workcell must be 
in Manual mode to teach a path program online with PathMaster®. Refer to the workcell 
manual for more information. 

NOTE: Playback of a path is only possible if workcell is in Manual mode. 

 Teach Pendant 

PVA workcells come with a teach pendant. Each teach pendant has a Trackball, Teach 
button, Purge button, Axis selection button, and LED indicators for selected axes and 
teach function.  

 
Figure 69: Teach Pendant 

LED’s – The X, Y, Z and W LED’s show the selected axis configuration. The Teach LED shows 
a position was correctly recorded by PathMaster®. The light tower buzzer will “beep” when 
the Teach LED illuminates. 

NOTE: W-axis trackball control is locked if the Teach Tool is enabled, unless the PathMaster 
Tool Offset window is open (Setup-> Machine Parameters-> “Tool Offsets”). This so the 
operator does not teach an accidental theta position with the teach tool. 
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 Fiducial Function 

NOTE: When you work with fiducials, the workpiece is usually a PCB and will be referred to 
as a PCB in this section and its sub sections (Section 9). 

PathMaster® uses fiducials to make sure the part that is dispensed on is correctly installed 
in the work area. A fiducial is an object in the field of view of the imaging system used as a 
reference point. The shape and size of the fiducials must obey the SMEMA Fiducial Mark 
Standard (Standard 3.1). You must have PVA Portal Vision Module 1.04 or higher, and 
Firmware D220S36S or higher for the motion controller to use the fiducial functions in 
PathMaster®.  

The fiducial function will do an inspection of fiducial A or B to correct for the translational 
(X and Y) and rotational offset (skew) of a product. To correct for skew, the product must 
have an A and B fiducial mark and the skew must be within an acceptable tolerance. The A 
and B fiducials should be located diagonally opposite one another. 

The skew tolerance is set in the inspection program profile from the Portal Manual teach 
window. The tolerance is a radius in millimeters from the center of the expected fiducial 
location. The measured center of the fiducial must fall within this radius to pass the check. 
Refer to the Portal Manual. 

Program and run fiducial A before fiducial B. 

 

Figure 70: Example Fiducial 

 Fiducial A  

When fiducial A runs, X and Y offsets are cleared, and the tool moves to the taught 
absolute gantry position. When the tool is in position, the programmed fiducial parameters 
are run. A pass / fail status is shown. If the result is a pass, an XY offset is reported to the 
controller.  

NOTE: There is a box so the XY offsets are not cleared when fiducial A is run. Do not select 
this box unless there is a reason.  
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 Fiducial B  

Fiducial B uses the offset found by fiducial A to move the tool to the corrected fiducial B 
coordinates. When the tool is in position, the programmed fiducial parameters are run. The 
fiducial B function finds if the part is skewed and if the amount of skew is within tolerance. 
A pass/fail status is shown based on the skew tolerance. The calculated skew is applied to 
the machine. 

 Fiducials and Skew Correction 

 Translational Correction 

PathMaster® uses translational correction in the fiducial function. The fiducial function will 
find the center of the fiducial on the PCB (Workpiece) and calculate the translational 
correction to be applied to the path program. Translational correction will be applied to all 
path segments that follow the fiducial function in the program table. 

 Rotational Correction 

PathMaster® finds the necessary rotational correction with a Fiducial A function followed 
by a Fiducial B function. The Fiducial A function calculates and applies the translational 
correction to fiducial B to find fiducial B on the PCB. When fiducial B is found, the rotational 
correction is calculated by the angular difference between the actual fiducial B location 
(Angle1) and the expected fiducial B location (Angle2). You must run fiducial A before 
fiducial B because the translational correction from the Fiducial A function is necessary to 
find fiducial B.  

 Calculations 

DeltaX1 = (FidB[X]Expected – FidA[X]Actual) 

DeltaY1 = (FidB[Y]Expected – FidA[Y]Actual) 

DeltaX2 = (FidB[X]Actual – FidA[X]Actual) 

DeltaY2 = (FidB[Y]Actual – FidA[Y]Actual) 

Angle1 = ArcTan(DeltaY1 / DeltaX1) 

Angle2 = ArcTan(DeltaY2 / DeltaX2)AngleSkew = (Angle1 – Angle2) 
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 Corrected Space 

Corrected space is a virtual coordinate system used by PathMaster® to adjust for 
rotational correction. The virtual coordinate system (or PCB coordinate system) rotates the 
XY gantry coordinate system by the skew angle. The coordinates are rotated around 
fiducial A, as related to the current PathMaster® tool. The virtual coordinate system is used 
to run, playback, or teach a path program that is skewed relative to the machine coordinate 
system. PathMaster® enters corrected space automatically when Fiducial A and B 
functions are run. The fiducial icon illuminates to show you are in corrected space.  

PathMaster® shows the virtual coordinates (PCB coordinates) when in corrected space, 
not the gantry coordinates. You can teach and edit in PathMaster® while in corrected 
space. When you teach or edit a path in corrected space the coordinates recorded in the 
program table are different from the coordinates that you taught on the part. PathMaster® 
automatically teaches the path in normal, “uncorrected” space. If you move to a position in 
the path while in corrected space, the tool will be in the correct position on the part, but 
the coordinates may not match the coordinates that you moved to. This is because 
PathMaster® automatically adjusts for translational and rotational offset. With this 
adjustment you can run the path on a part that has been placed correctly in the system 
and does not need fiducial correction. If you open or change a program, edit a fiducial, 
select the Clear Fiducial function from the Main menu, or enter Tool Offset Setup menu you 
will exit corrected space. 

 
Figure 71: Normal Space 



 
Machine Operation Manual 

 

Revision L / February 2020 Page 74 of 200 

 

 

Figure 72: Corrected Space 

 Teaching Fiducials 

1. Select the Fiducial function. 

2. Select the necessary Inspection and Light. 

3. Select the Fiducial. Fiducial A must be programmed first. 

4. Teach Fiducial A. 

 
Figure 73: Teach Fiducials 

The fiducials will show on the edit screen in blue. 

5. Double click on the fiducial function to edit the fiducial. 

6. Select “Teach” to save changes made under Fiducial Parameters.  
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Figure 74: Fiducial Window 

7. Select “Edit Position” to change the position of the fiducial. 

8. Select “Teach Position” to teach the location of the end effector, or put the 
coordinates in the Teach Coordinate box and select “Teach Coordinate”. 

 
Figure 75: Edit Fiducial  

9. Select “Teach” when you are done to exit and save the changes you have made, or 
select “Cancel” to exit and not save changes. 

 Run Fiducials 

Run fiducials before any online programming. 

1. Select Run Fiducials from the programming toolbar. 

2. The status will show in a window, either pass or fail. 

NOTE: If the fiducials have not been run and an online programming tool is selected, you 
will be asked if you want to continue without the fiducials run, paths that contain a fiducial 
that has not been run will not allow surface editing.  

3. Double click on the Position section of the Lower Status Bar to see the current XY 
offset and skew angle. 

 
Figure 76: Global Offset and Skew 
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 Programming Functions 

 General Function Parameters and Buttons 

The following function definitions apply to 2D path, 3D path, Arc, Circle, and Area tools.  

Current Position – If there is communication with the controller, the current position is 
shown in the text box. Use the teach pendant on the workcell to change the position. 

Input Coordinates –Enter the target position manually. 

Dispensing Parameters – Select parameters for the current dispense and the active tool.  

Tool On Wait – The pause after the tool is turned on before the dispense path starts. 

Tool Off Wait – The pause after the path is finished and the tool is off, but before the tool 
moves to the next point.  

Tool On Distance – The distance of the path traveled before the tool turns on. 

Tool Off Distance – The distance of the path traveled when the tool is turned off, but 
before the path is finished. 

Z Retract (Relative) – Distance to raise the Z-axis after certain moves are completed. 

Teach – Records the current point. 

Surface- Drop down menu to select the end-effector height. Menu options depend on the 
function.  

• Gantry (Raw) uses the Z coordinate exactly as it was taught.  
• Gantry (Relative) uses the Z coordinate that was taught and subtracts the “Relative 

Height” numeric field’s current value.  
• Calibrated Z uses the Run Tool Reference Z for the current run tool and subtracts 

the global “Relative Height” set for that tool in Tool Configuration. 
• Use Last uses the Z height of the previous Surface used in the Polyline.  
• Custom Surface uses the XY coordinates of the Surface command that shares the 

same name and uses the Z height and the current run tool’s “Calibrated Z” to set the 
dispense Z height. 

Use Current Z Height – This will teach all coordinates at the current end-effector height. 

Use Calibrated Z Height – This will teach all coordinates at the end-effector height taught 
during teaching offsets. The final calibrated height is the tool offset Z Height minus the 
“Relative Height” parameter set for the tool in Tool Configuration. 

Done – Adds all edits to the program.  

Cancel – Exit without changes to the program. 
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NOTE: Playback can only operate if the workcell is in Manual mode. 

NOTE: When teaching a position on a 4-axis machine the last coordinate in the list (0.000, 
0.000, 0.000, 0) is the theta value. Theta is measured in encoder counts and is always a 
whole number.  

NOTE: Teach tool selections only apply when the teach tool is used.  

 Add Comment  

1. Select the add comments icon from the tool bars.  

2. Add a comment to each path program so anyone who views the path program can 
understand the program. All comments are removed from the program on 
compilation and do not use any controller memory. 

 
Figure 77: Comment 

 DMC  

 With this function the user can enter DMC code into the program. Only users who 
understand the DMC language should use this. 

 
Figure 78: DMC Command Programmed 

1. Select the DMC function. 

2. Enter the correct command into the Edit DMC window. 

3. Select “Done” to save the changes.  

4. Select “Cancel” to exit and not add a command. 

 
Figure 79: Edit DMC 
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 Plugin Select  

Plugin Select is where the user can select which plugins are used. 

1. Select the Plugin Select icon or select Plugins->Plugin Select from the main menu 
bar. 

 
Figure 80: Plugin Select Menu 

 
Figure 81: Plugin Select 

2. Use the radial buttons to sort the plugins as necessary by Name, Category, or 
Description. 

3. Select necessary plugin so it is highlighted. 

4. Select “Done”. 

A plugin specific window will be shown. Refer to plugin specific documentation for more 
information. 
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Figure 82: Example Plugin Window 

Plugins will be shown on the program table with the Command as “PLUGIN” and the plugin 
specific name shown in the Other column.  

 

Figure 83: Example Programming  

 Plugin Download Error 

Plugins are not available to projects that are downloaded to the controller. Portal 
PartManager must be used to select programs if plugins are used. If an attempt is made to 
download or export a Project that contains plugins, an error will be shown.  

 

Figure 84: Plugin Warning 
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 Dwell  

Set a delay in program execution in between path segments with the Dwell function. 

1. Select the Dwell function. 

2. Put the correct value in the Wait box.  

 
Figure 85: Teach Dwell 

3. Select “Teach” to add the command to the edit screen.  

4. Select “Cancel” to exit and not add a command. 

 Move  

The Move command is a non-dispense move. The approach type is applied globally to all 
points taught within a single move command and determined by the selected approach 
type when the “Done” button is clicked. If more than one approach type is necessary, teach 
multiple move commands. Refer to Section 10.1 for definitions of the tool functions. 

 
Figure 86: Move Command in the Edit Screen 

1. Select the Move function. 
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Figure 87: Tool Move 

2. Select the Approach Type.  

3. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. 

4. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. 

5. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

6. Select the Surface from the drop-down menu. Gantry (Raw) uses the current Z 
height, Calibrated Z uses the calibrated Z height, Gantry (Relative) the user to sets a 
move in Z axis relative to the taught position (mostly used for knit-line finishing).  

7. Use the teach pendant or input the commands in the Input Coordinates box and 
select “Teach”.  

8. Click “Teach” at the next move point as necessary.  

9. Select “Done” to close the window. 

10. To edit a Move command, double click on the path and change the command in the 
edit window. Refer to Section 7.5. 
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 2D Path  

This tool teaches 2D path segments. The Z-axis does not change its position in the path. 
Refer to Section 10.1 for definitions of the tool functions. 

 
Figure 88: Programmed 2D Line Command 

13. Select the 2D Path function. 

 
Figure 89: Teach 2D Line 

14. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. Refer to Figure 68. 

15. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68. 

16. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

17. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

18. Set the Path Speed. 

19. Set the Tool On to “Wait” or “Distance” and set the time or distance in the box. 

20. Set the Tool Off to “Wait” or “Distance” and set the time or distance in the box. 

21. Select the “Teach” button or use the teach pendant to input the commands in the 
Input Coordinates box.  

22. Select “Done” to save the changes, or “Cancel” to exit and not save changes. 

23. To edit a 2-D path, double click on the path and edit in the window shown. Refer to 
Section 7.5.  
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 3D Path  

This function teaches 3D path segments. Refer to Section 10.1 for definitions of the tool 
functions. 

 
Figure 90: Programmed 3D Line Command 

1. Select the 3D Path function. 

 
Figure 91: Teach 3D Line 

2. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. Refer to Figure 68. 

3. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68. 

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

5. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

6. Set the Path Speed. 

7. Set the Tool On to “Wait” or Distance” and set the time or distance in the box. 

8. Set the Tool Off to “Wait” or “Distance” and set the time or distance in the box. 

9. Select the “Teach” button or use the Teach pendant to input the commands in the 
Input Coordinates box.  

10. Select “Done” to save the changes, or “Cancel” to exit and not save changes. 

11. To edit a 3-D Path, double click on the path and change the command in the edit 
window. Refer to Section 7.5.  
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 PolyLine (DMC 4000)   

A Polyline is a path made of lines and arcs. Polylines are used when it is necessary to 
change direction quickly, at high speeds, during a dispense. Polyline, in Pathmaster® 4.3, 
uses surface height readings (taught before a polyline is used). Surface Height readings 
and the Calibrated Z Height of a tool (Section Error! Reference source not found.), account 
for differences in individual part height and paths are adjusted to dispense correctly. 

 New Polyline 

1. Click on the Polyline or select Teach > Polyline > Create New from the Main Menu to 
open the Polyline Teach Interface.  

 
Figure 92:PolyLine Teach Window 

2. The Bomb button ‘explodes the polyline’. All the taught segments and arcs move 
into the main path program as separate segments. When a line is exploded, the 
height profiling feature cannot be used.  

3. When 2D Polyline is enabled, a single Z height is taught for all the polyline segments. 
Select the “2D Polyline” checkbox to use this option. 

4. Select either a Polyline or Arc from the top of the Polyline teach window. Follow the 
prompts to teach the points. 
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Figure 93: Polyline Line Segment Teaching 

5. Use the Coordinate Selection radio buttons and Surface dropdown selection to Z 
coordinate options. The radio buttons select between: 
Live Coordinates: The end effector’s current gantry position. 
Type Coordinates: User types in the coordinates with the keyboard. 
Surface Coordinates: Where the Surface Height commands, that are valid for this 
polyline, were taught. 

 
Figure 94: Teach Radio Buttons 

NOTE: Only surfaces that are in the program grid and are in the path program before the 
point of insertion of the polyline will be in the dropdown. 

6. Use the Surface drop-down menu to set the Z-plane for a selected Polyline point.  

 

Figure 95: Teach Surface Dropdown 

• Gantry (Raw) uses the Z coordinate exactly as it was taught.  

• Gantry (Relative) uses the Z coordinate that was taught, and subtracts the “Relative 
Height” numeric field’s current value.  

• Calibrated Z uses the Run Tool Reference Z for the current run tool, and subtracts 
the global “Relative Height” set for that tool in Tool Configuration. 
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• Use Last uses the Z height of the previous Surface used in the Polyline. The first 
point of a new Polyline cannot use this selection. 

• Custom Surface uses the XY coordinates of the Surface command that shares the 
same name and uses the Z height and the current run tool’s “Calibrated Z” to set the 
dispense Z height. 

NOTE: Surfaces are named in the Path Segment before the Polyline being taught. 

7. Click the green highlighted button above the Polyline Segment table to end the line. 

8. Select the “Speed” column for an individual segment and type the value to change 
it. Highlight multiple segments to change multiple values.  

9. To edited line segments, use the buttons to the right of the Polyline Segment table. 
The top button is used to add a new point into a line, and the bottom button to 
remove a single point from a line, or remove an entire arc.  

NOTE: After a new point is taught to a line, the segment is de-latched automatically. 

 
Figure 96: Polyline Segment Table Edit Buttons 

NOTE: If a line segment only has two points, the entire line will be removed if “Remove” is 
selected. If a segment does not have the necessary number of points, it is removed from 
the polyline list. Line segments must have at least two points, but can have more. Arcs 
must have exactly three points. 

10. Highlight a point and click “Move To” to move to the selected point.  

 
Figure 97: Move to Coordinate Enable/Disable 

11. Click the bar under any active axis to disable movement and editing of that axis by 
turning the indicator yellow. 

12. When all desired segments are taught, click “Done” to save the Polyline and add it to 
the Path Program, or “Cancel” to return to the main PathMaster® window without 
saving. 



 
Machine Operation Manual 

 

Revision L / February 2020 Page 87 of 200 

 

 Create from Selected 

1. To create a Polyline from individual path segments, select the path segments to 
include in the Polyline.  

2. Select the Teach menu.  

3. Select Polyline -> From Selected Lines.  

If the endpoints of the path segments do not match up, PathMaster® will ask to match up 
the endpoints. If you do not to match up the endpoints the Polyline will not be made. If you 
select match up the endpoints, the polyline will use the best fit. 

The newly created Polyline will default to using the Raw Gantry height of the integrated 
path segments. Entering the Polyline edit window allows the user to make use of Surface 
Height readings and Relative Heights. Circles are re-generated into two arcs. 

WARNING! PathMaster® will use the tool used in the first segment for all the segments. 
Make sure all individual paths segments in a polyline use the same tool. 
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 PolyLine (Legacy and DMC2000)  

A PolyLine is a path made of 2 dimensional lines, arcs, and circles. PolyLines are used when 
it is necessary to change direction quickly at high speeds during a dispense. Paths with 
lines, arcs, and circles will have smoother movement and more uniform corners and circles 
if created as a polyline. 

There are two ways to make a polyline. Individual path segments can be made and then 
changed to a polyline, or via the Polyline tool. 

 New PolyLine 

When teaching a segment in a polyline, the last point of the previous segment will be used 
as the first point of the new segment. For example, only two points of a polyline arc need to 
be taught (if it is not the first segment of the polyline) because the first point will be the 
last point of the previous segment. 

4. Open the Polyline function from the top menu Teach > PolyLine. 

5. Select a programming tool from the toolbar on the left.  

 
Figure 98: PolyLine Window 

6. Teach the points required for the tool selected. 

7. Set the Path Speed. 
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Figure 99: Teach a Point 

As each segment is created, it is added to the command list on the left of the Polyline 
program table. The polyline is limited to 2047 points for all segments.  

8. Select a command from the list of commands. 

9. Set the Dispensing Parameters.  

10. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When using the “Teach 
Tool” (virtual tool 0), it is not necessary to select this button.  

11. Select a segment in the command list and select the “Edit Point” button or the “Edit 
Speed” button to edit the points and speed for each segment.   

12. The Polyline can also be exploded into individual path segments and modified on the 
main PathMaster® program table.  

 
Figure 100: PolyLine 

13. Select “Done” to save the completed polyline or select “Cancel” to exit and not save 
changes. 

14. To edit, double click on the path segment and change the command in the edit 
window. Refer to Section 7.5. 
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 From Selected Line 

15. To create a polyline from individual path segments, select the path segments to 
include in the Polyline.  

16. Select the Teach menu.  

17. Select Polyline -> From Selected Lines.  

If the endpoints of the path segments do not match up, PathMaster® will ask to match up 
the endpoints. If you do not to match up the endpoints the polyline will not be made. If you 
select match up the endpoints, the polyline will use the best fit. 

 
Figure 101: PolyLine Point Match Up 

When a polyline is made from individual path segments, the tool parameters will be from 
the first path segment in the series. The speeds for each path segment will be kept. 

WARNING! PathMaster® will use the tool used in the first segment for all the segments. 
Make sure all individual paths segments in a polyline use the same tool. 

18. To edit a polyline, double click on the path and change the command in the edit 
window. Refer to Section 7.5. 

 Polyline3D (Legacy and DMC2000)  

 A Polyline3D is a single continuous dispensing path that allows motion in the X, Y, and Z 
Axes. There are two ways to make a polyline. Individual path segments (2D/3D lines or 
Arcs) can be made and then changed to a polyline, or you can use the Polyline tool. 

 
Figure 102: Programmed 3D Polyline Command 

 New Polyline3D 

When you teach a segment in a polyline, the last point of the previous segment is used as 
the first point of the new segment. For example, it is only necessary to teach two points of 
a polyline arc (that is not the first segment of the polyline) because the first point will be 
the last point of the previous segment. 
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1. Open the Polyline3D function. 

2. Select a programming tool from the Polyline toolbar on the left.  

 
Figure 103: Polyline3D Teach/Edit 

3. Teach the points necessary for the tool selected, input the coordinates or use the 
teach pendant. 

4. Set the Path Speed.  

As you make each segment, it is added to the command list on the left of the Polyline 
program table. The polyline is limited to 2047 points for all segments.  

5. Select the command from the Command list and set the Dispensing Parameters.  

6. To edit the points and speed for each segment, select a segment in the command 
list and select the “Edit Point” button or the “Edit Speed” button.  

The Polyline can also be exploded into individual path segments and modified on the main 
PathMaster® program table. 

7. Once the Polyline is complete select “Done” to save the changes or select “Cancel” 
to exit and not save changes. 
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 From Selected Line 

8. To create a polyline from individual path segments, select the path segments to 
include in the Polyline.  

9. Select the Teach menu.  

10. Select Polyline -> From Selected Lines.  

If the endpoints of the path segments do not match up, PathMaster® will ask to match up 
the endpoints and the polyline will use the best fit. If you do not to match up the endpoints 
the polyline will not be made. Refer to Figure 101.  

The tool used for the first segment and the θ (Theta) position, will be used for the 3D 
Polyline command. This function is helpful when dispensing gaskets and odd shaped 
adhesive patterns where it is necessary to change height but have a continuous flow of 
material. 

11. To edit a polyline, double click on the path and change the commands in the edit 
window. Refer to Section 7.5. 
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 Arc  

This function teaches an arc. An arc must have three points. The Z-axis does not change 
its position in the path. Refer to Section 10.1 for definitions of the tool functions. 

 
Figure 104: Programmed Arc Command 

1. Select the Arc function. 

 
Figure 105: Teach Arc 

2. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. Refer to Figure 68. 

3. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68. 

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

5. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

6. Set the Path Speed. 

7. Set the Tool On to “Wait” or “Distance” and set the time or distance in the box. 

8. Set the Tool Off to “Wait” or “Distance” and set the time or distance in the box. 

9. Teach the three points. Include the start point and move (clockwise or counter-
clockwise) in the direction the axes must move. Use the teach pendant or input the 
coordinates. 

NOTE: When you select points, space them evenly around the arc. 

10. Select “Done” to save the changes, or “Cancel” to exit and not save changes. 

11. To edit an Arc, double click on the path and change the command in the edit 
window. Refer to Section 7.5. 
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 Circle  

This function teaches a circle. A circle must have three points. The Z-axis does not change 
position in this path. Refer to Section 10.1 for definitions of the tool functions.  

NOTE: When you select points, space them evenly around the circle. Do not use the same 
point for the first and last point. 

 
Figure 106: Programmed Circle Command 

1. Select the Circle function. 

 
Figure 107: Teach Circle 

2. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. Refer to Figure 68. 

3. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68. 

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

5. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

6. Set the Path Speed. 

7. Set the Tool On to “Wait” or “Distance” and set the time or distance in the box. 

8. Set the Tool Off to “Wait” or “Distance” and set the time or distance in the box. 

9. Select three points on the circumference of the circle. Include the start point and 
move (clockwise or counter-clockwise) in the direction the axes must move. 

10. Select “Done” to save the changes, or “Cancel” to exit and not save changes. 

11. To edit a circle, double click on the path and change the command in the edit 
window. Refer to Section 7.5. 

NOTE: You can only operate Playback if the workcell is in Manual mode. 
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 Tool  

With this tool the user can enter a tool (tool) command into the edit window. Only tools that 
are configured in machine parameters are shown in this window. 

 
Figure 108: Programmed Tool Command 

1. Select the Tool function. 

2. Select the Run Tool.  

3. Select (double click) the necessary tool from the window. Refer to Figure 68. 

 
Figure 109: Tool Window 

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

5. Select the Action from the dropdown menu. 

 
Figure 110: Tool Dropdown Menu 

6. Select “Teach” to save the command, or “Cancel” to exit and not save the 
command.  

7. To edit a tool command, double click on the tool command in the program table to 
open the Tool Command window. 

Pneumatic positions (tool up/down, rotary selection) are not automatically programmed by 
PathMaster®. The operator must select the correct tool in PathMaster® and put the 
necessary pneumatic commands in the program after a path has been completed. Refer to 
Section 10.14 for more information. 
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 Dot   

This function teaches a timed dispense over a coordinate point.  

 
Figure 111: Programmed Dot Command 

1. Select the Dot function. 

2. Teach the point with the teach pendent or input the coordinates.  

 
Figure 112: Teach Dot 

3. Select the Run Tool. Select (double click) on the necessary tool from the window. 
Refer to Figure 68. 

4. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68. 

5. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

6. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

7. Make sure the Z Retract value is correct. 

8. To edit the dot, double click on the path and change the command in the edit 
window. Refer to Section 7.5. 
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 Dot Array  

Select any two corners of the array to create the array. The order the dots are taught 
determines the direction of the array. The program will automatically calculate the number 
of dots and the row spacing based on the set values.  

1. Select the Dot Array function. 

2. Select the Run Tool. Select (double click) on the necessary tool from the window. 
Refer to Figure 68. 

3. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68.  

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

5. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

6. Set the Tool On and Tool Off settings in seconds. Use the keyboard to type the 
values.  

7. Set the Z Retract (Relative) setting in counts. Use the keyboard to type the value. 

 

Figure 113: Create Dot Array 

8. Set the number of dots for the X-axis.  

9. Set the number of dots for the Y-axis.  

10. Set the Direction for the dot array from the drop-down menu, either “X then Y” or “Y 
then X”. 

11. Teach the Dot 1 position. Move to the necessary position and select “Teach”. In the 
example, this is the top left-hand corner of the array. 



 
Machine Operation Manual 

 

Revision L / February 2020 Page 98 of 200 

 

12. Teach the Dot 2 position. Move to the necessary position and select “Teach”. In the 
example, this is the bottom right-hand corner of the array. 

NOTE: The order you teach the dots in determines the direction of the array. 

 
Figure 114: Dot 1 and 2 

A window will show that the dots are generating.  

 

Figure 115: Generating Dots 

13. Select “Done” when you are finished.  
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 Area  

This function teaches rectangular paths. The Z-axis does not alter its position during the 
path. Refer to Section 10.1 for definitions of the tool functions. 

 
Figure 116: Programmed Area Command 

1. Select the Area function. 

 
Figure 117: Teach Area 

2. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. Refer to Figure 68. 

3. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68. 

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

5. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

6. Set the Path Speed. 

7. Set the Tool On to “Wait” or “Distance” and set the time or distance in the box. 

8. Set the Tool Off to “Wait” or “Distance” and set the time or distance in the box. 

9. Select the three points. Include the start point and move (clockwise or counter-
clockwise) in the direction the axes must move. 

10. Select “Done” to save the changes, or “Cancel” to exit and not save changes. 

11. To edit an Area, double click on the path and change the command in the edit 
window. Refer to Section 7.5. 
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NOTE: Playback can only be operated if the workcell is currently in Manual mode. Only three 
points are required for the Area tool. 

 How the Area Function Works  

Area path segments are calculated with three points as shown below: 

Point 1 defines the start of the pattern. Point 2 defines the direction and length of the 
pattern. After the direction of the pattern is determined, the distance from point 1 to point 
3 determines the width of the pattern.  

The width is divided by the ‘Area Spacing’ (or ‘Path Spacing’) parameter on the Area 
function screen. The value given is the number of passes needed to fill the given area. 

 Area #1 Area #2 

 

                    
      

 

 

 

 

Area #1  

• Point 1 defines the start. 

• Point 2 is along the X-axis, so that is the direction of the path. The length of the 
path is the distance over the X-axis. Therefore, the width is along the Y-axis. 

• Point 3 defines the width. The width is the difference in Y between points 1 and 3. 
This is divided by the ‘Area Spacing’ (or ‘Path Spacing’) parameter resulting in the 
number of paths the machine needs to run to fill the given area. 

Area #2  

• Point 1 defines the start. 

• Point 2 is along the Y-axis, so that is the direction of the path. The length of the 
path is the distance over the Y-axis. Therefore, the width is along the Y-axis. 

• Point 3 defines the width. The width is the difference in X between points 1 and 3. 
This is divided by the ‘Area Spacing’ (or ‘Path Spacing’) parameter resulting in the 
number of paths the machine needs to run to fill the given area.  

Point

1 1 

2 

2 

3 3 

X 
  

Y 
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 FastArea™ 

FastArea™ is faster than the standard area because it prevents tool cycling between rows. 
This feature can greatly decrease cycle time. The way coordinates are taught with 
FastAreaTM is different than a normal area. Each point defines the 3 corners of the 
rectangle, and the path will fit into area. Refer to the figure below. 

 
Figure 118: Fast Area 

1. To use the FastArea™ feature teach a standard area. Refer to Section 10.17. 

2. Select the type of fast area to be used (Disabled, Rectangular, Arcs). 

 

Figure 119: Fast Area 

3. Select “Done” to save the changes, or “Cancel” to exit and not save changes. 

4. To edit a FastArea, double click on the path and change the command in the edit 
window. Refer to Section 7.5.  
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 FastMask™  

The FastMask™ function will create an area to be coated and keep outs within that area. 
There can be up to 99 keep out areas specified within the coating area.  

 
Figure 120: Programmed FastMask Command 

Shown below is an example of a PCB (Printed Circuit Board) with keep out areas specified. 

 
Figure 121: Sample Board with Keep out Areas 

1. Select the FastMask™ function to open the wizard. 

2. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. Refer to Figure 68. 

3. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68. 

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button.  

5. Set the Tool Height to “Use the Current Z Height” or “Use Calibrated Z Height”. 

6. Set the Tool On to “Wait” or “Distance” and set the time or distance in the box. 

7. Set the Tool Off to “Wait” or “Distance” and set the time or distance in the box. 

8. Set the Path Speed. 

9. Set the Area Spacing. 

10. Select the appropriate tool parameters.  

11. Teach two opposite corners of the area to be coated as point 1 and point 2.  

Sample 

Keep outs 
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Figure 122: FastMask Area Teach 

12. Select the “Next” button.  

13. Teach the opposite corners of the first keep out area.  

14. Select the “Add” button to add the keep out to the FastMask™ list.  

 
Figure 123: Keep Out Teach Menu 

15. Continue to add keep out areas (up to 99 keep outs) until all non-coat areas have 
been included in the FastMask™ list. 

16. Select the “Next” button. 
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17. Select the Spray Pattern. This is the direction the tool will go when this FastMask™ 
pattern is used.  

 
Figure 124: FastMask Brush Stroke Pattern 

18. Select the “Next” button.  

 
Figure 125: FastMask Complete 

19. Select the “Finish” button. 

The FastMask™ pattern will always start at the point taught closest to the origin of the 
gantry (the smallest coordinate in the pattern). 

20. To edit a FastMask, double click on the path and change the command in the edit 
window. Refer to Section 7.5.  
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 Rectangular Spiral  

This creates a square spiral pattern with an area defined by the user. This is one continuous 
dispense and is used when a material is unable to be equally spaced with the area 
command. There are 3 points, the 1st point is the start, the 2nd point is direction, and the 
3rd point gives the size. The Z-axis does not change position in this path. 

 
Figure 126: Rectangular Spiral Programmed 

1.  Open the Rectangular Spiral function. 

 
Figure 127: Teach Rectangular Spiral 

2. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. Refer to Figure 68. 

3. Select the Teach Tool if necessary. Select (double click) the necessary tool from the 
Tool Selection window. Refer to Figure 68. 

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

NOTE: The “θ” button will only be available on 4-axis machines. When you use the “Teach 
Tool” (virtual tool 0) it is not necessary to select this button. 

5. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

6. Put the necessary value in the Path Speed box. 

7. Teach the points. Point 1 is where the path starts. Point 2 is the direction of the 
path. Point 3 uses the diagonal distance between 1 and 3 to find the size.  

8. Set the Tool On and Tool Off to “Wait” or “Distance” and set the time or distance in 
the box. 

9. Set the Line Spacing.  

10. Select “Done” to save the changes or “Cancel” to exit and not save changes. 

11. To edit, double click on the path and use the edit window. Refer to Section 7.5. 
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 Circular Spiral  

This creates a spiral pattern with an area defined by the user. The command is taught like 
an arc command. It uses 3 points where the 1st point is the start, the 2nd point is direction, 
and the 3rd point forms a diagonal with the 1st point to determine size. In this tool, line 
spacing is the pitch or distance between arcs and direction refers to in or out direction of 
the path. The Z-axis does not alter its position during the path. 

 
Figure 128: Spiral Programmed 

1. Open the Spiral function. 

 
Figure 129: Teach Spiral 

2. Select the Run Tool. Select (double click) the necessary tool from the Tool Selection 
window. Refer to Figure 68. 

3. Select the Teach Tool. Select (double click) the necessary tool from the Tool 
Selection window. Refer to Figure 68. 

4. Select “θ” to move the selected tool to the calibrated W-axis position (theta). 

5. Select the Surface from the drop-down menu. In some units, you can set the 
Relative Height. 

6. Put the necessary value in the Path Speed box. 

7. Set the Path Speed. 

8. Teach the points required for the tool selected. Point 1 is where the path will start. 
Point 2 is the direction of the path. A diagonal line between point 1 and point 3 gives 
the size of the rectangle.  
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9. Set the Tool On to “Wait” or “Distance” and set the time or distance in the box. 

10. Set the Tool Off to “Wait” or “Distance” and set the time or distance in the box. 

11. Set the Line Spacing.  

12. Set the Direction to “In” or “Out”. 

13. Select “Done” to save the changes or “Cancel” to exit and not save changes.  

14. To edit a rectangular spiral, double click on the path and change the command in 
the edit window. Refer to Section 7.5. 
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 Surface Height (DMC 4000)  

The Surface Height command is used to teach surfaces used in PolyLines. The surfaces 
should be run in order, to count the different surfaces before the related paths are run. The 
process is similar to fiducials. 

1. Click on the surface height icon in the Programming Toolbar to open the surface 
height interface.  

2. Use the tool parameters subsection to find the necessary profile tool and teach tool 
to teach surfaces for the current product.  

 

Figure 130: Surface Height Teach Interface 

3. If necessary, set a min/max for each surface height in the surface height teach 
interface (in the tool parameters window). With these values, the machine can make 
sure a part is within a set tolerance for a surface height reading. This reading can be 
seen in the Portal front panel. 

NOTE: After a Surface Height call, if the Profile Tool selected is on the head on a Z-Slide, 
the user must program the necessary Tool Command to retract the Z-Slide. 

NOTE: In Autocycle, if a part fails a surface height you can try again. 

4. The Surface Name can be changed to any unique name on a per-program basis. 

5. If necessary, use the Theta button to rotate the W-axis to the correct position. 

 
Figure 131: Surface Command in Path Program 

6. Click “Teach” to set the Surface Height Position for the height check.  

7. Click “Done” to save the point and return to the main PathMaster® screen. 

8. Repeat the Procedure to teach as many Surface Height Checks as necessary. 
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 Run Selection  / Sequence  

The Run Selection function will play back the selected path segments in Wet, Dry or 
Camera mode. Run Sequence always plays the entirety of the Path Program. 

1. Select one or more commands. 

2. Select the Run Selection function to play the highlighted commands or Run 
Sequence to play all of the current Path Program. 

6. Select “Wet”, “Dry”, or “Virtual Tool 0”. The name for the third option will be the 
name of Virtual Tool 0.  

 
Figure 132: Playback 

3. Select “Start” to play the highlighted commands. 

4. Select “Close” to exit and not play the path. 
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 Z-Axis Height 

NOTE:  The “Use Current Z Height” and “Use Calibrated Z Height” checkboxes are only 
shown when the Teach Tool is enabled. The Tool Offset table and Tool Parameters must be 
correctly configured before use. 

The teach tool can be used to make paths on the workcell. After a path segment is taught 
with the teach tool, the tool can be changed to any other tool and the offset is set by 
PathMaster.  

The Z-axis (height) position is set by the user when path segments are taught, the teach 
tool’s current Z-coordinate or a pre-calculated value, called the Calibrated Tool Height, can 
be used. If the calibrated tool height is used, it will not be necessary to change the path 
after it is complete, and when tool changes or needle calibrations are done, the offsets are 
update for the path programs. 

Tool Offset Height: The distance traveled by a specific tool from the Z-axis home position 
to the workpiece. 

Relative Height: The Z distance from the position taught as the tool offset reference 
position on the calibration plate that the tool will operate at, set in the Tool Configuration 
window. Also called Gantry (Relative) in the Surface menu. Not available for 2D Line, 3D 
Line, Area, Arc, Circle, Dot, Dot Array, Rectangular Spiral, and Spiral. Functions slightly 
differently when used in the Move command. 

Calibrated Z Height:  The difference between a tool offset and the tool’s Relative Height is 
the Calibrated Z Height for a tool. Also called Calibrated Z, in the Surface menu. 

Calibrated Z Height = Tool Offset Height – Relative Height 

Additional Options in the Surface Menu: 

Gantry (Raw) uses the Z coordinate exactly as it was taught.  

Use Last uses the Z height of the previous Surface used in the Polyline. Not available for 2D 
Line, 3D Line, Area, Arc, Circle, Dot, Dot Array, Rectangular Spiral, Spiral, and Move. 

Custom Surface uses the XY coordinates of the Surface command that shares the same 
name and uses the Z height and the current run tool’s “Calibrated Z” to set the dispense Z 
height. 

NOTE: The available Z-height options depend on the workcell configuration and the 
function being used.   
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 Offset Details 

The offset height is shown in PathMaster’s Tool Configuration window and set in the 
Camera Offset Training window. Refer to Section 6.6.5 for more information.  

• Select the Offset Details button to be shown the related tool offset. 

 
Figure 133: Example Tool Offset 

Run Tool Reference – This is the absolute position where the Run Tool is positioned to 
calculate the tool offset. 

Teach Tool Reference – This is the absolute position where the Teach Tool is positioned to 
calculate the Tool Offset. 

Run Tooling Offsets – This is the difference in position between the Teach Tool and the Run 
Tool (Tool Offset). 

Tool Profile Offset – This is the difference between the Profile Z Common reference and 
the tip of the Run Tool (Profile Offset). 
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 Relative Height 

The Relative Height is shown in PathMaster’s Tool Configuration window (Figure 134). This 
value must be correctly set or the workpiece or workcell could be damaged. This value can 
be found in Setup -> Machine Parameters -> Tool Parameters for each tool. 

 
Figure 134: Relative Height Input Box 
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 Calibrated Z Height 

The following functions have the ability to make use of “Calibrated Z Height” or the Surface 
menu options Gantry (Raw), Calibrated Z, and Custom Surface: 

• Tool Move 
• 2D Line 
• 3D Line 
• Arc 
• Circle 

• Dot 
• Reference Point 
• PolyLine 
• PolyLine3D 

• Spiral 
• Rectangular 

Spiral 
• Area 
• FastMask 

 

Figure 135: 2D Path with Tool Height 

• When “Use Current Z Height” is selected and a point is taught, the Z-axis coordinate 
used is the current Z coordinate of the machine, as shown in the Lower Status Bar. 

 
Figure 136: Z-Axis Coordinate in the Lower Status Bar 

• When “Use Calibrated Z Height” is selected and a point is taught, the saved Z-axis 
coordinate is the selected tool’s calculated tool height. When a user selects “Use 
Calibrated Z Height,” the following message is shown: 

 
Figure 137: Override Tool Height 
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• If “No” is selected, the “Override Tool Height” checkbox will be automatically 
selected again, and no change will take place. If “Yes” is selected, all the points that 
have been taught in the current path segment and any future points in the current 
path segment will have the selected Calibrated Z Height value as the Z-axis 
coordinates.  

  How to Use the Tool Height Options  

There are two ways to change the Tool Height options as shown below. 

• When you teach a path select “Use Calibrated Z Height” or “Use Current Z Height,” 
or select an option from the drop-down Surface menu. Available options depend on 
the workcell configuration and the function.  

 
Figure 138: Teach Window Tool Height 

• After a path has been taught you can change the settings in the Edit window. Refer 
to Figure 67. 

All necessary offsets are automatically set by PathMaster.  
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 Example 

In the example below, the first 2D line is shown with the “Use Current Z Height” selected at 
the Z height of zero. There is no offset shown, and so the displayed value is zero. For the 
second 2D line, the first function was copy and pasted, another Run Tool was selected and 
“Use Calibrated Z Height” was selected.  

 

Figure 139: 2D Lines Before and After Switching Tools  

The difference in coordinates from the first 2D Line and the second, show XYW offsetting 
and the calibrated height has been used for Z. 

 Offline Programming (FastPath) 

When you use FastPath (the teach tool must be enabled), all taught positions will use the 
tool height values for the Z position. This makes the transition from programming offline to 
online easier. 
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 Step Over  

The Step Over function allows playback of previous or next path segment to be executed 
one step at a time as well as playback wet or dry. 

1. Select the Step Over function, select Main Menu > Utilities > Step Over Path. 

2. Select the correct Option Wet, Dry, or Teach Tool. 

3. Select the Command you want to play with the “Backward” and “Forward” buttons. 
The highlighted command in the edit window is the command that will play. 

 

Figure 140: Step Over Path 

4. Select “Play” to operate the path segment as selected. 

5. Select “Close” to exit and not play a path. 
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 Additional Functions 

There are other functions that are not in the programming functions toolbar. Their 
locations and information on how to use them are in this section. 

 Subroutine 

With this function the operator can use a command line element in an array sequence or in 
random placement. Individual subroutines can be put in the program with the Insert option.  

 To Create 

1. Highlight the commands to be included in the subroutine. 

2. Select the Teach -> Subroutine -> Create option from the main menu. 

 
Figure 141: Subroutine Menu 

3. Choose a name and description for the subroutine. The description helps the 
operator to select the correct subroutine. 

 
Figure 142: Name the Subroutine 
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4. Teach a reference point on the part to group the command line sequences. Each 
subroutine, arrayed or random placed, will be referenced from this point.  

 
Figure 143: Teach a Reference Point 

5. Select Create an array or Place random for the subroutine. 

 
Figure 144: Subroutine Type 

6. Select “Next”. 

For place random, continue to step 7. For create an array continue to step 10. 

 Place Random 

7. Select the “Teach Position” button for PathMaster® to record the current location 
of the end effector as an execution point. Or, enter the necessary coordinates in the 
Teach Coordinates box and select “Teach Coordinates”. 
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Figure 145: Place Random Routine 

8. Select “Next” when you have taught all the necessary coordinates. 

9. Select “Finish”. 

 Create an Array 

10. Select the direction of the array. The arrows show direction as related to X, Y 0, 0 
origin of the current machine. 

 
Figure 146: Create an Array Routine 

11. Select the number of elements in the X direction and the Y direction. 

 
Figure 147: X and Y Elements 
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12. Teach the first and last points. The coordinates entered are relative to the point of 
origin taught before. PathMaster® calculates the distance for X and Y spacing. 

 
Figure 148: Teach First and Last Points 

 Finish 

13. Select “Finish” to save the subroutine, or “Cancel” to exit and not save changes. 

 
Figure 149: Finish Window 

 Edit the Subroutine 

1. Save the current project.  

2. Select File -> Open -> Subroutine and choose the subroutine from the list. 

3. Edit the routine as necessary. 

4. Save the subroutine and open the current project again. 
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 I/O (Input/Output) 

The operator can control outputs or wait for an input to be in a set state. Only operators 
who understand discrete I/O and its use should use this tool.  

  
Figure 150 Teach I/O 

1. Select Teach->I/O from the main menu. 

2. Select the necessary function.  

3. Select “Wait for input” to hold the program until an input is in the set state. Select 
“Set Output” to turn a discrete output on or off. 

4. Put the necessary value in the Bit # box. This is the location of the discrete I/O bit 
referenced. 

5. Select the necessary Value, “ON” or “OFF”.  

6. Select “Teach” to add your selections to the program or “Cancel” to exit and not 
save changes. 
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 Move Speed Change Command 

The Move Speed Change command is used to change the speed of independent axis 
movements between dispense points. This command does not change the speed at which 
the gantry moves when dispensing. All movements between dispenses are changed by this 
command. This may be utilized multiple times in a path to change the rate of motion at any 
time. 

To access the Move Speed Change command, click Teach > Move Speed from the main 
menu. 

 
Figure 151: Move Speed Change Window 
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 Inspection  

The function moves to the taught gantry position with X and Y offsets applied. Once the 
tool is in position, the inspection program and light type DMC parameters are set and the 
DMC inspection routines are called. The vision module reports a pass/fail status to the 
controller based on the inspection result defined with the inspection project. 

 
Figure 152: Teach Inspected 

1. Select Teach->Inspection from the main menu. 

2. Set the Inspection to be used.  

3. Set the Light to be used. 

4. Input the coordinates or use the teach pendant to teach the coordinates.  

5. Select “Teach”, or select “Cancel” to exit and not change the command. 
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 Clear Global Offsets  

Clear any X, Y, Z, or W offset associated with the GX, GY, GZ, and GW variable.  

 
Teach Clear Global Offsets 

1. Select Teach->Clear Global Offsets from the main menu. 

2. Select the boxes you want the global offsets cleared from. 

3. Select “Teach” to clear the offsets (X, Y, Z, W). 

4. Select “Cancel” to exit and not change the command. 
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 Motion Smoothing 

The motion smoothing command is a jerk limiting function applied to independent and 
vector motion profiles. You must have a DMC4000 or DMC 4200 series motion controller to 
use this function.  

1. Select the Motion Smoothing function from the Teach menu. 

 

Figure 153: Motion Smoothing 

 
Figure 154: Motion Smoothing Window 
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2. Select the Axes boxes you want the smoothing to be applied to. If an axis is not 
checked, no smoothing change will be applied to that axis.  

3. Select a percentage of smoothing within the configured range in the motion 
smoothing interface window. The smoothing percentage is applied to all axes with 
checked boxes. 

4. Create multiple smoothing commands to use different smoothing values for 
different axes.  

5. When a smoothing function is used, it is applied to all motion that follows in that 
path program or until another smoothing command is applied. Smoothing is reset at 
the beginning of every path by default. 

 Smoothing Examples: 

No Smoothing applied can cause overshooting on corners. 

 
Figure 155: No Smoothing Applied 

Smoothing applied minimizes the following error on corners. 

 

Figure 156: Smoothing Applied 
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 Offline Programming with FastPath 

Before you use FastPath™, tool offsets must be configured. Refer to Section 6.6.5 for more 
information.  

When you are in FastPath your cursor is a crosshair. Each time a point is taught the 
crosshair will briefly change to an arrow pointer to show that the point was taught. 

 Set Up a Background Image 

1. Open a new program. 

2. Select Edit->Program->Offline Image from the main menu.  

3. Select “Change Image” to change the background image. If no image is selected, the 
default image will be used. The default image is a 500mm by 500mm image with a 
workspace of the same size. The background image must be of a known size, 
approximately the same size as the area to be dispensed upon.  

4. Put the correct values in the Workpiece Dimensions boxes for Board Length and 
Board Width. 

 
Figure 157: Background Image 

5. Select “Size Image”.  
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Figure 158: Choose Points  

6. Select “OK”. 

7. Select the first point on the image that shows in the Choose Reference Point 
window. 

 
Figure 159: Select the First Point 

8. Select “OK”. 

9. Select the second point. 

10. Enter the value of the length between the points in the box. 

11. Select “OK”. The Work Piece Dimensions will be updated. 

 
Figure 160: Enter the Length between Points 

12. Choose the Reference Point Type.  

NOTE: A good reference point is the lower right of your image and the tool 1 coordinates for 
the intersection of the front rail and the board stop of your machine.  

13. Find the machine coordinates for the same location.  

14. Put the tool 1 coordinates in the Robot Reference Point edit boxes. 

15. Select “Teach Reference Point”. 

16. Select “Apply” to save the changes. 

17. Select “Cancel” to exit and not save changes. 
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 Tool Selection 

With Tool Selection the tool for path segments in FastPath™ can be selected. Tool selection 
is important because tool offsets are applied. 

The tool offsets must be setup before FastPath™ is used, for the path program to run 
correctly. Select the necessary tool before you select a programming tool. You can change 
the tool, but it must be selected before the path segment is completed.  

For example: If the first two coordinates of an area are taught with tool 2 and tool 3 is 
selected to complete the third point, the path segment will use tool 3. 

 Drawing a Program 

1. Select the FastPath™ icon on the programming toolbar to open the FastPath™ 
window.  

2. Use the “Zoom-In” and “Zoom-Out” buttons to adjust the image size.  

3. Select a tool to make a path segment. 

4. Teach the necessary functions for the tool selected. 

5. Close the FastPath™ window and to return to the PathMaster® window. 

 

Figure 161: FastPath 

Most PathMaster® programming functions are available when in FastPath™. Programming 
functions are used in FastPath™ similar to the way they are used for regular programming. 
The FastPath™ points are taught on the board image in the FastPath™ window with the 
corresponding tool selected, instead of with the teach pendent. 

6. To modify or edit an object, double click on the function.  
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The following functions are used in offline programming the same way they are used in 
online programming: 

 NOTE: Each path segment taught corresponds to the tool selected in the FastPath™ 
toolbar. 

• Move 
• Tool 
• Area 
• Spiral 
• Rectangular Spiral 

• FastMask™   
NOTE: The FastMask™ will be shown on the board image as a blue coating area with red 
keep outs. 

• Dot 

The following functions are different in FastPath offline programming, their uses are 
described below. 

 2D Line 

The 2D Line function makes a line up to 2047 points.  

1. Select the 2D Line button.  

2. Select all the points of the line on the image.  

3. When you have taught all points, right click the mouse to complete the 2D Line.  

 
Figure 162: FastPath 2D Line 

The line on the board image will have a dispense width equal to the area spacing parameter 
of the selected tool (Setup-> Machine Parameters->”Tool Parameters” -> Line Spacing). 
The 2D line can be edited graphically.  
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 Arc 

The Arc function has two endpoints and a mid-point.  

1. Select the Arc function.  

2. Teach the three points. 

 
Figure 163: FastPath Arc 

Double click on the arc to open the edit screen.  

 Circle 

The center point is displayed for reference and cannot be moved. 

1. Select the Circle function.  

2. Teach the three points. 

 
Figure 164: FastPath Circle 

Drag any point of the circle to a new location to edit it. This will change the radius and 
location of the entire circle. 
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 Password Protection 

Password protection can be added to the download and save functions in PathMaster® to 
prevent unauthorized or accidental changes to project files. 

 Download Password 

Password protection can be added to the download function in PathMaster®.  

1. Select Setup -> Password -> Set Download Password from the main menu.  

If no password exists, you will be asked if you would like to create one. If a previous 
password exists, you must enter it correctly to continue.  

2. Enter the new password. 

3.  Select “OK”.  

4. Enter the password again.  

5. Select “OK”.  

The PathMaster® Download Project and Download Main functions are now password 
protected. A password will be necessary to download with these functions. If the password 
is entered incorrectly, the download is canceled. 

 Resetting Password 

1. To reset the save or download password, do the procedure to set the download or 
save password. 

2. Enter a new password in the new and confirm password fields. 
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 How to Import and Export Files 

The PathMaster® can import and export programs, projects, and subroutines. It can also 
import CAD files. 

 CAD Files 

A 2-dimensional CAD drawing can be imported into PathMaster® as a path program. 

There are several steps required for a successful import. These include: 

• Create the path drawing in CAD. 

• Add the PathMaster® codes to the CAD drawing. 

• Turn the CAD drawing to the correct position as it relates to the workcell gantry. 

• Export the CAD drawing to a *.dxf (Autodesk Drawing Exchange Format). 

• Import the CAD drawing into PathMaster® with the CAD wizard. 

• Prepare the CAD File. 

NOTE: The CAD X+ and CAD Y+ arrows are for reference only and are not necessary. 

 
Figure 165: Original CAD Image 

1. The start and end of each segment must be labeled as shown in the image above 
and as described in the table below.  

2. Put the units in the CAD drawing as shown. 



 
Machine Operation Manual 

 

Revision L / February 2020 Page 134 of 200 

 

Required Element Description 

BEGIN1, BEGIN2, etc. Defines the start of the segment. The tool will turn ON at this 
point. 

END1, END2, etc. Defines the end of the segment. The tool will turn OFF at this 
point. 

UNITS=IN.  
UNITS=MM.  
UNITS=CNTS. 

Defines the units used for creating the drawing. 

 

NOTE: The path will be converted automatically to the units specified in PathMaster® when 
it is imported. 

3. After all necessary elements have been put in the drawing it must be mirrored on 
the Y axis.  

NOTE: In AutoCAD be sure to “Delete Old Objects” when prompted. 

 
Figure 166: CAD Drawing Mirrored on the Y Axis 

4. Rotate the drawing clockwise 90° (-90° for standard AutoCAD Setup).  

 
Figure 167: Rotate the CAD Drawing 90° 
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The final step is to export the file to a *.dxf. 

5. In AutoCAD select the File->Export menu. 

6. When the Export Data window comes up, select “Save As” Type AutoCAD 
R12/LT2DXF. 

7. Under the Options button make sure that the Export Format is ASCII. 

8. Give the file a name and save it. 

 How to Import a DXF file into PathMaster 

The path will be imported to a new program.  

1. Select File ->Import ->Program ->DXF File from the main menu.  

2. Select the Tool that will be used with the imported CAD file.  

3. Select the “Next” button. 

 
Figure 168: Select the Tool 

4. Set the Snap to tolerance. 

 
Figure 169: Set the Tolerance 
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The snap to tolerance is the maximum distance between points where the points are 
considered connected. If the distance between the points is more than this value the 
points will not be connected. 

 
Figure 170: Snap to Tolerance 

NOTE: The snap to tolerance makes sure the translation of the drawing entities is correct. 

5. Select the “Next” button. 

6. Select the method of importation as either Paths from Begin to End or All Entities. 

“Paths from Begin to End” will import the file as drawn, with the segment order 
(BEGIN1,END1, etc.) kept as shown. “All Entities” ignores commands for order but is useful 
for large files with many paths, where each segment is not numbered. 

 
Figure 171: Import Method 

7. Teach the start point of the path. You can use the teach pendant or type the 
position. 

8. Select “Next”. 
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Figure 172: Teach the Start Point 

9. Select the file to import. 

 
Figure 173: Import Flies 

After a successful import the path will be displayed in a path preview window. 

 
Figure 174: Path Preview  

The file will be imported as individual paths (Line, Arc, etc.). The paths are ready for 
playback or may be made into a Polyline. 
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 PathMaster 1.5 and Pre 1.5 Projects 

PathMaster® 1.5 and earlier projects can be imported into the current version of 
PathMaster®. 

1. Select File -> Import -> Project -> PathMaster 1.5 or Pre PathMaster 1.5 option from 
the main menu.  

2. When the file dialog box opens, select the location and the file name of the project 
to import.  

3. Select “Open”.  

NOTE:  You may need to change the file filter (type) to *.txt, or *.dmc to see the project file 
in the dialog box. 

 PathMaster PRJBCK Files 

PathMaster® Project Backup files (PRJBCK) can be imported and exported.  

 To Import 

1. Select File -> Import -> Project -> Project File (PRJBCK) option from the main menu.  

2. When the file dialog box opens, select the location and the file name of the project 
to import.  

3. Select “Open”.  

 To Export 

1. Select File -> Export -> Project - > Project File (PRJBCK) option from the main menu.  

2. When the dialog box appears, select a location and file name for the program. 

3. Select “Save”. 

 Text File 

A correctly formatted tab delimited text file can be imported into PathMaster® as a path 
program. PathMaster® can also export text files. 

 To Import  

1. Select File -> Import -> Program -> Text File option from the main menu.  

2. When the file dialog box opens, select the location and the file name of the project 
to import.  

3. Select “Open”.  

A text file program is typically a file that was exported as a text file from PathMaster®. 

NOTE:  You may need to change the file filter (type) to *.txt to see the project file in the 
dialog box. 
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 To Export 

1. To export a program to a tab delimited text file, select File -> Export -> Program -> 
Text File option from the main menu.  

2. When the dialog box appears, select a location and file name for the program. 

3. Select “Save”. 

 DMC File 

A correctly formatted DMC file can be imported into PathMaster® as a path program. 
PathMaster® can also export DMC files.  

 To Import 

1. Select File -> Import -> Program -> DMC File option from the main menu.  

2. When the file dialog box opens, select the location and the file name of the project 
to import.  

3. Select “Open”.  

NOTE:  You may need to change the file filter (type) to *.dmc to see the project file in the 
dialog box. 

 To Export 

1. Select File -> Export -> Project - > DMC File or Compressed DMC File from the main 
menu.  

2. When the dialog box appears, select a location and file name for the program. 

3. Select “Save”. 

 Compressed DMC Machine File 

All of a workcells project files can be exported to compressed DMC Files. 

1. Select File -> Export -> Machine - > Compressed DMC File from the main menu.  

2. When the dialog box appears, select a file folder location. 

3. Select “Save”. 
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 Subroutine 

A correctly formatted subroutine can be imported into PathMaster® with the import 
subroutine option. PathMaster® can also export subroutines. 

 To Import 

1. Select File -> Import -> Subroutine -> Text File option from the main PathMaster® 
menu or the File -> Import subroutine option from the subroutine edit window 
menu.  

2. Select the location and name of the subroutine.  

3. Select “Open”. 

NOTE:  You may need to change the file filter (type) to *.txt to see the project file in the 
dialog box. 

When the import is complete, the subroutine edit window will open. Refer to Section 7.5. 

 To Export 

1. Select File -> Export -> Subroutine -> Text File option from the main PathMaster® 
menu or the File -> Export Subroutine option from the subroutine edit window 
menu.  

2. Select the location and name of the subroutine.  

3. Select “Save”. 
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 Modify 

PathMaster® has functions to help change completed paths. These functions can be found 
in the Modify menu. 

Program 

Select this option to offset or mirror the entire program. 

Selection 

Select this option to make changes to only the blue highlighted portion of the program. 

 Properties 

Select Modify -> Properties to open the selected commands edit window. Refer to Section 
10 for more information on specific programming functions. 
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 Offset 

Select Modify -> Offset to see the options Program and Selection. 

 Offsetting a Path 

1. Select Modify -> Offset.  

2. Select either Program or Selection. 

3. In the boxes for ‘X Offset’, ‘Y Offset’, ‘Z Offset’, and  ‘W Offset’, enter the desired 
offset in the units shown. 

  
Figure 175: Offset Program Window Without and With Teach Tool Enabled  

4. Click ‘OK’. 

Your program/selection has been correctly offset.  

NOTE: If you Offset W you could cause unintended consequences, and will override existing 
offsets when the teach tool is enabled. Re-teaching a selected command will reset the W 
to the pre-taught offsets. 
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 Mirroring a Path 

NOTE: It is not possible to mirror and offset a program simultaneously. 

1. Select Modify -> Offset.  

2. Select either Program or Selection. 

3. Select ‘Mirror across robot y axis’ and/or ‘Mirror across robot y axis’. See ‘Mirror 
Help’ for an image and description of each action.  

 
Figure 176: Mirror Help Window 

4. Move the robot to the necessary reference point for the path. This point is used to 
group the selected path components and will also act as the reflection point. 

5. Click the first “Teach” button. 

6. Move the robot to the new location. This location will be used as the origin of the 
location, based on the first reference point select. 

7. Click the second “Teach” button. 

8. Click “OK”. 

Your program/selection is now mirrored.  

NOTE: This will only mirror the X and Y axes and will not affect the Z or W axes. 
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 Rotate 

 Rotating a Path 

1. Select Modify -> Rotate.  

2. Select either Program or Selection. 

3. Move the robot to the necessary center point for the path. This point is used as the 
point to rotate the path around. 

 
Figure 177: Rotate Path Window 

4. Enter the degrees you would like to rotate the program. This will rotate the program 
counter-clockwise. 

5. Click ‘OK’. 

Your program/selection has now been successfully rotated.  

NOTE: This will only mirror the X and Y axes, and will not affect the Z or W axes. 
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 Speed 

 Modify Speed 

1. Select Modify -> Speed.  

2. Select either Program or Selection. 

3. Select either “Increment/Decrement Speed” or “Replace Speed”. 
Increment/Decrement Speed will offset all speeds in in each command by the value 
given. Replace Speed sets each command at the value given. 

 
Figure 178: Modify Speed Window 

4. Click “OK”. 

Your program/selection speed has now been changed.  

NOTE: If you change the speed you override existing speeds that are pre-programmed in 
the tool configurations. New commands use the default tool configuration values. Move 
Speed command values are not affected by this modification. 
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 Tool Parameters 

 Modify Tool Parameters 

1. Select Modify -> Tool Parameters.  

2. Select either Program or Selection. 

3. For “Tool On” select either “No Change”, “Wait”, or “Distance”. 

4. Enter the new value in the box to the right. 

5. For “Tool Off” select either “No Change”, “Wait”, or “Distance”. 

6. Enter the new value in the box to the right. 

 
Figure 179: Modify Tool Parameters Window 

7. Click “OK”. 

The tool parameters have now been updated. 

NOTE: If you change the tool parameters you override existing speeds pre-programmed in 
the tool configurations. New commands will use the default tool configuration values. 

NOTE: Only commands with the same tool may be selected at the same time. You may not 
change multiple commands that have different tools at the same time. 
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 Subroutine Call 

 Selection 

This option changes which subroutine will be called at runtime. You must highlight the 
subroutine to be changed or this modification will not work. 

 Modifying a Subroutine Call 

1. Select Modify -> Subroutine Call.  

2. Select Selection. 

3. Select the necessary subroutine to replace the existing subroutine. Use the search 
bar to help you find the new subroutine if necessary. 

4. Click “Call”. 

 
Figure 180: Select New Subroutine 

The subroutine has been updated to the selected subroutine. 
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 Area Spacing 

 Modify Area Spacing 

1. Select Modify -> Area Spacing.  

2. Select either Program or Selection. 

3. Enter the new desired spacing in the text box. 

 
Figure 181: Area Spacing 

4. Click “OK.” 

All selected areas now have an updated spacing. 
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 Utilities 

PathMaster® has functions to help with debugging the workcell and path programs. These 
functions can be found under the Utilities menu. 

 View FastPath 

Open the FastPath™ window for offline programming.  

• Select Utilities -> View FastPath option from the main menu.  

NOTE: The FastPath™ window can also be accessed using the FastPath™ button on the 
programming toolbar. 

 Measure Distance 

The measure distance tool is used to find the distance between two points in current 
measurement units.  

• Select Utilities -> Measure Distance option from the main menu.  

 To Measure Distance  

1. Move the tool to the first point with the teach pendant. 

2. Select “Teach Point 1”.  

3. Move the tool to the second point with the teach pendant. 

4. Select “Teach Point 2”.  

5. Select “Calculate Distance”. The distance will be calculated and shown. 

 
Figure 182: Distance Measurement 

6. Select “Close” when you are finished. 
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 Refresh Communication 

If PathMaster® loses communication with the workcell the communication must be 
refreshed. 

• Select Utilities -> Refresh Communications from the main menu. If communication 
is not reestablished, check cables and communication settings. 

 Jog Toolbar 

The jog toolbar can be used to jog the X or Y axis a specified distance.  

1. Select Utilities -> Jog Toolbar from the main menu.  

2. Enter the distance to jog, and select the button with the necessary axis and 
direction. 

 
Figure 183: Jog Toolbar 
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 Path Preview 

The path preview will give a graphic representation of the path program or segments.  

1. Highlight all path segments to be displayed in the preview.  

2. Select the Utilities -> Path Preview option from the main menu. The path preview 
window will display. 

 
Figure 184: Path Preview 

3. Right click the path preview window to see a zoom, pan, rotate, coordinate info 
menu.  

4. Select “Reset” to return the preview to default display. 

5. Select “Ok” when you are done.  

 Recover Main and Recover Project 

With the Recover Main and Recover Project features the user can upload the compressed 
main or compressed project from the controller.  

1. Select Utilities-> Recover MAIN or Utilities ->Recover Project from the main menu.  

2. When the dialog box appears, select a file folder location. 

3. Select “Save”. 

NOTE: The files will be compressed and in DMC, so the files will not be easy to change. 
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 Show Code and Show Code with Surfaces 

The show code option will show the compiled machine code for the selected segments. 
Show Code with Surfaces is used as a debug tool, if necessary, and replaces all of the 
variables with values used. 

1. Highlight the path segments. 

2. Select Utilities -> Show Code from the main menu, or right click and select Show 
Code from the menu. 

 
Figure 185: Show Code 

A window will open with the machine code from the selected segments.  

3. Select “Save As” to save the code as a text file. 

4. Select “Print” to print the code. 

 
Figure 186: Show Code, Command Preview 
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5. If the selected segment uses surfaces, run the surface, the text will be green when 
it has passed. 

6. Highlight the necessary path segments and select Show Code from the menu. 

 
Figure 187: Show Code with Surfaces Menu 

A window will open with the machine code from the selected segments.  

 

Figure 188: Show Code with Surfaces, Command Preview 

7. Use the necessary buttons to “Save As” or “Print”. 

8. When you are done select “Done”. 
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 Line Check 

Use this function to see how many lines of compressed DMC code the current program will 
occupy. 

1. Select Utilities -> Line Check from the main menu. 

A window will open with the number of lines. 

 
Figure 189: Line Check 

2. Select “OK” when you are finished. 
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 Machine Debugger 

The machine debugger is an array of tools to aid in the debugging of the .  

1. Select Utilities -> Machine Debugger from the main menu.  

When the machine debugger opens, select the tab for the tool to be used each tab is 
described below. 

 Terminal 

The terminal lets the operator send commands directly to the controller. To send a 
command to the controller, make sure the keyboard caps lock is on. 

1. Type the command in the terminal window. 

2. Push the Enter key.  

A response from the controller will display under the command that was issued. If the 
controller does not understand what it received, it will respond with a “?”. 

 
Figure 190: Machine Debugger Terminal 

For more information on how to use the terminal or how to work directly with controller, 
refer to the online controller manual. Refer to the Troubleshooting manual for more 
information on DMC code. 
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 Digital I/O 

The digital I/O tool allows for you to toggle most digital I/O points on the controller. Select 
the button for the I/O point you wish to toggle. The buttons will change colors when the I/O 
point changes state. The refresh interval is the frequency of the tool display refresh in 
milliseconds. 

 
Figure 191: Utilities Machine Debugger Digital I/O 

 Analog Input 

The analog input tool will monitor the voltage of analog input feedback. The refresh interval 
is the frequency of the tool display refresh in milliseconds. 

 
Figure 192: Machine Debugger Analog Input 
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 Resources 

The resources tool monitors the controller resources such as available program labels, and 
program variables. The type of resources displayed on this form will change with the model 
of controller used. 

 
Figure 193: Machine Debugger Resources 
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 Variable Watch 

The Variable Watch tool will monitor a list of program variables entered by the user.  

3. Type a valid program variable name into the watch list on the left. 

4. Select “Start Watch” and the value of the variable will be displayed on the right.  

Multiple variables can be monitored at the same time. The refresh interval is the frequency 
of the tool display refresh in milliseconds. 

5. Select “Clear Values” to erase the value shown. 

6. Select “End Watch” to no longer watch that variable. 

 
Figure 194: Variable Watch 
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 DMC Programming Basics 

• All commands must be in uppercase letters. 

• Positions are given in counts. In most cases there are 5080 counts per inch, 200 
counts per millimeter.  

• No line of code may contain more than 80 characters. 

• A semicolon (;) is used as a carriage return. This allows for multiple commands on 
the same line and can be used to save space in the program. 

 Labels 

Sections of a program (subroutines) are defined by labels. PathMaster® generates its own 
labels for programs. These labels do not appear in the edit window, so the operator cannot 
alter them. 

• Labels start with the pound (#) sign followed by a maximum of seven characters.  

• The first character must be a letter, after there can be numbers.  

• There can be no spaces.  

• There can be no duplicate labels anywhere in memory. The Main program and 
PathMaster® are written without any duplicate labels.  

• If the operator must put special labels into programs it can cause duplicate labels. If 
any duplicate labels occur, the operator must find the duplication and fix it. 

This usually happens when a section of code has been copied and pasted. There can be no 
duplicates anywhere within a project, which includes all 30 programs in that project. 

• Labels must be at the start of a line. When code is entered manually, make sure 
there are no labels in the middle of a line. This causes an error when the program is 
run. 

 Important Commands 

The DMC programming language contains over 135 commands. The program for the 
workcell does not use most of these commands, and even fewer are used to create a 
dispense path.  

The commands in the table below are the most important for an advanced operator to 
know. A complete list of commands can be found in the separate DMC-4000 or 4200 
manual that came with the machine. Any reference to manually changing or querying in 
the examples below requires the use of the terminal option in PathMaster® to 
communicate directly with the controller. 
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Cmd Description Example Tips 

AC Acceleration for 
independent moves are in 
counts per second squared 

AC*=100000 (sets all 
axes) ACX=100000 
(only sets the X axis 
acceleration) 

Make sure the acceleration is 
large enough to get the 
motion to speed in a 
reasonable amount of time 

AM After move. This command 
holds the program until the 
movement on the specified 
axes is completed 

AM (wait for all axes to 
finish its motion) 

AMS (wait for 
coordinate sequence 
to finish motion) 

The AM command tests for 
profile completion. Use the AM 
command to separate multiple 
movements 

AV After vector distance. This 
command holds the program 
until a specified distance 
has been traveled with a 
coordinated move, the units 
are in counts 

AV1000 (wait until the 
axes have moved 1000 
counts) 

The AV command resets to 
zero after every use. It can be 
calculated by summing the 
distances between each point 
on the coordinated move 

BG Begin. BG starts a motion on 
an axis or a sequence 

BGX (begin motion on 
the X axis), BGS (begin 
motion sequence), BG 
(begin motion on all 
axes) 

A second BG command 
cannot be given until the first 
BG motion is finished. The AM 
command can hold the 
program until the first motion 
is done. The exact axes to put 
in motion must be given. The 
BG command starts all the 
axes according to the last 
specified motions 

BL Reverse Software Limit   
CB Clear bit. Clears a bit on the 

output port 
CB40 (clears the bit for 
the buzzer) 

Clearing a bit in DMC 
terminology turns the bit on. 
The opposite of CB is SB (set 
bit). A complete list of the 
outputs can be found in the 
Operating Guide 
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CR Circle. Select a radius, a start 
angle and the angle to be 
traversed. Movement is 
counterclockwise in the 
Cartesian coordinate 
system. This is either 
clockwise or 
counterclockwise, as viewed 
from the front of the 
machine, and depends on 
the setup of the machine. A 
negative traverse angle 
yields clockwise motion in 
the Cartesian coordinate 
system 

CR 5000,90,180  

arc with length of 5000 
counts, starting at 90° 
and doing a half circle 
(180°) 

The circle command is a 
coordinated two-dimensional 
move. The structure is the 
same as all other coordinated 
moves, using the VM, VP and 
VE commands. A start angle of 
0° gives a circle, relative to the 
start point, entirely negative in 
the X direction and half 
positive, half negative in the Y. 
Starting at 180° yields an 
entirely positive X circle and a 
half positive, half negative Y.  

90° is an entirely negative Y 
circle  180° entirely positive Y, 
with both having X half 
positive, half negative 

CS Clear Sequence Clears Memory of prior coordinated sequences 

DC Deceleration for 
independent moves. The 
units are in counts per 
second squared 

DC*=100000 (sets all 
axes), DCX=100000 
(only sets the X axis 
deceleration), DC 
10000,30000,40000 
(sets X, Y and Z 
Decelerations 
separately) 

The higher the deceleration, 
the faster an axis stops its 
move 

DE Dual (Auxiliary) Encoder 
Position 

  

DL Download. This transfers a 
text file from the computer 
to the controller  

DL (then select a text 
file to download) 

Use the HX (halt execution) 
command before using DL. 
Damage may result otherwise  

EN End. This terminates a 
subroutine, program thread 
or program  

EN The Dispensing System also 
has a subroutine used for a 
conditional end. The command 
JP#NOOP operates the same as 
the EN command 

FL Forward Software Limit   
HX Halt execution. Halts the 

execution of the program or 
any of its threads 

HX1 (halt thread 1) 

HX (halt the entire 
program) 

Always use the HX command 
before executing a DL 
command 
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JG Jog   

JP Jump to a program location. 
Locations are marked by 
labels. This command can be 
used in a conditional 
statement and the jump 
occurs if the conditional is 
true 

JP#NOOP (jump to 
location #NOOP), 
JP#NOOP,COUNT>10 
(jump to location 
#NOOP if the value of 
COUNT exceeds 10) 

It is important not to confuse 
JP with JS. Using a JP when a 
JS is required results in the 
thread being halted once the 
EN command is reached 

JS Jump to subroutine. 
Subroutines are marked by 
labels 

JS#H1UP (jump to 
subroutine #H1UP) 

It is important not to confuse 
JS with JP. Using a JS when a 
JP is required can result in 
“nesting” the program 
continuously until a nesting 
error occurs. Subroutines can 
only be nested 16 deep 

LI Linear Interpolation Distance   
LM Linear Interpolation Mode   

LS List. The operator can list a 
single line or multiple lines of 
the program in a terminal 
screen 

LS 300,0 (show line 
300), LS 250,270 
(show lines 250 to 
270), LS (show all 
lines in memory) 

If a runtime error occurs, use 
the LS command in the 
terminal screen to check the 
line containing the error 

MG Message. This command 
sends data out the bus. It 
can also be used by the 
operator to query the 
controller for information  

MG “Path Complete” 
(displays the message 
“Path Complete” on 
the terminal screen), 
MG@IN[60] (displays 
the value of input 60, 
where 0 is on and 1 is 
off) 

Do not put message commands 
in programs! If there are 
message commands, and there 
is no computer attached to the 
workcell, the controller halts 
once the output buffer is full 

MO Motor off. Shuts off motor 
control 

MO (turn all motors 
off), MOX (turn off 
only the X axis motor) 

 MO shuts off the motor(s).The 
motors are reactivated with the 
SH (servo here) command 

MR Reverse Motion to Position   
MT Motor Type   
NO No operation. This command 

performs no action and is 
used to comment a program 

NO!!! PROGRAM 1!!!! 
(description for 
program) 

A semicolon (;) terminates the 
NO command. Any statements 
following a semicolon are 
executed 
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PA Position absolute. This sets 
the destination of a move, 
referenced to the origin. The 
units are in counts 

PA 10000,10000,1000 
(commanded position 
for X, Y and Z axes), 
PAX=10000 
(commanded position 
of X axis) 

It is best to limit the use of the 
PA command to designating 
the start of a dispense path. 
Overuse of the PA command 
complicates program editing 

PF Position Format   
PR Position relative. This sets 

the incremental position of 
the next move, referenced 
to the current position. The 
units are in counts 

PR 10000,10000,1000 
(commanded change 
in position for X, Y and 
Z axes), PRX=10000 
(commanded change 
in position of X axis) 

Be careful not to confuse PA 
with PR. The PR command 
begins its move from the 
current position, without 
reference to the origin 

RS Reset. Resets the controller 
to its power on state. All the 
information in the 
controller’s RAM is erased 

RS If PathMaster® fails to 
download a file correctly; the 
program may be halted in the 
controller. Executing an RS 
command from the terminal 
screen restarts the program 

SB Set bit. Sets a bit on the 
output port 

SB40 (sets the bit for 
the buzzer) 

Setting a bit in DMC 
terminology turns the bit off. 
The opposite of SB is CB (clear 
bit). A complete list of the 
outputs can be found in the 
Operating Guide 

SH Servo here. The controller 
uses the current position as 
the command position and 
enables motor control 

SH (activate all 
motors)                  SHZ 
(activate only the Z 
motor) 

The opposite of SH is MO 
(motor off) SH resets all 
position errors to zero 

SP Speed. Sets the speed for 
independent moves. Units 
are in counts per second 

SP*=100000 (sets all 
axes), SPX=100000 
(only sets the X axis 
speed), SP 
10000,30000,40000 
(sets X, Y and Z 
speeds separately) 

Make sure the value of the 
acceleration is high enough to 
get the motion to speed in a 
reasonable amount of time 

ST Stop. Halts motion on the 
specified axes. If no axes are 
specified, it halts program 
execution 

STX (stop motion on 
the X axis), ST (stop 
all motion and halt the 
program) 

Use the AM command after the 
ST command to wait for motion 
to be stopped 



 
Machine Operation Manual 

 

Revision L / February 2020 Page 164 of 200 

 

TB    

TC Tell error code. Displays the 
number and a text 
description for a command 
error 

TC1  

TD Tell Dual Encoder   

TE Tell error. This returns the 
current position error of the 
motors. Units are in counts 

TE Use this command in the 
terminal screen if a motor 
appears to be working 
incorrectly. The Dispensing 
System is programmed to 
disregard errors of less than 
1000 counts 

TP  Tell Position. Returns the 
current position of the 
motors 

TP (All axes) 

TPX (X axis only) 

Use in the terminal screen to 
verify the current location of 
the motors. In addition, the 
Manual mode of the workcell 
has a push button that 
accomplishes the same task 

VA Acceleration for coordinated 
moves. The units are in 
counts per second² 

VA 100000  Make sure the value of the 
acceleration is high enough to 
get the motion to speed in a 
reasonable amount of time 

VD Deceleration for coordinated 
moves. The units are in 
counts per second² 

VA 100000 Make sure the value of the 
acceleration is high enough to 
get the motion to speed in a 
reasonable amount of time 

VE Vector Sequence End   
VP Vector Position   
VS Vector Speed. Sets the 

speed for coordinated 
moves. Units are in counts 
per second 

VS 100000. Query the 
controller with the 
command MG_VS 

Make sure the value of the 
acceleration is high enough to 
get the motion to speed in a 
reasonable amount of time 

WT Wait. Holds program 
execution for specified time 

WT500  Use the WT command 
whenever the program needs 
to pause, particularly if another 
action needs time for 
completion 
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 Notes 
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 Warranty 

PVA Warranty Policy                 

PVA warrants the enclosed product against defects in material or workmanship on all 
components for one year from the date of shipment. 

The warranty does not extend to components damaged due to misuse, negligence, or 
installation and operation that are not in accordance with the recommended factory 
instructions. Unauthorized repair or modification of the enclosed product, and/or the use 
of spare parts not directly obtained from PVA (or from factory authorized dealers) will void 
all warranties. 

All PVA warranties extend only to the original purchaser. Third party warranty claims will 
not be honored at any time. 

Prior to returning a product for a warranty claim, a return authorization must be obtained 
from PVA’s Technical Support department. Authorization will be issued either via the 
telephone, facsimile, or in writing upon your request. 

To qualify as a valid warranty claim, the defective product must be returned to the factory 
during the warranty period. Upon return, PVA will repair (or replace) all components found 
to be defective in material or workmanship. 

 

(Retain this for your records) 

 

Product Information: 

PRODUCT:         ______________________________ 

SERIAL NUMBER:        ______________________________ 

DATE OF PURCHASE:    ______________________________ 
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 Appendix B- Definitions 
Auto Cycle – Automated workcell state where dispense cycles can be run. 

Cycle Stop – Stopped workcell state where no manual or automated action occurs and the 
workcell is at the standby position. Actions such as auto purge and solvent position moves 
may occur at set intervals.  

Database Backup File – A collection of projects, programs, tool configurations, and setup 
parameters for a single machine, typically with the extension .bck or .abck. 

NOTE: Prior to PathMaster 4.2 a database file could consist of multiple machines. This 
functionality has been deprecated in version 4.2. 

Database Transfer File – A collection of projects and programs used to transport machine-
level data from a source machine to a destination machine. A transfer file (.tfr) also 
includes the workspace reference position, along with Z offsets for each tool. A transfer file 
is similar to a database backup file, without the tool configuration and setup parameter 
data. 

Device – Any physical part processing device, such as a spray or dispense valve, a camera, 
or a laser. 

Dispense Path – A continuous motion profile. The tool is on (dispensing or spraying) during 
the entire motion profile, also known as a path.  

Dot Drop Mode – A mode to teach the teach tool to run tool offset. A dot of material is 
dispensed by the run tool and that dot is used as a reference to align the teach tool. 

DMC – Language used to program the motion controller in the workcell. 

End Effector – The dispense tool assembly. The end effector is moved by the axes. 

Home Position – The (0, 0, 0, 0) location of the workspace. This position is determined by 
the location of the home sensors. It is NOT the same as the Standby Position. 

Jog – One or more axes are commanded to move continuously at a specified speed 
(measured in encoder counts per second) until commanded to stop. 

Main Program File –The text file with the code to run the workcell in normal operation. 

Needle Calibration – The procedure to find the position of the tool’s needle relative to the 
expected position of the calibration sensors, the Tooling Offset is then corrected to match 
the found values. The difference is applied as a Program Offset. 

Needle Calibration Reference – Position where the crosshair on the needle calibration block 
is centered below the system’s teach tool. 

Offline Programming - A procedure to program path programs when not connected to the 
workcell, known as FastPath™. 
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Offset Details – An information screen that shows the teach Tool Reference Position, Run 
Tool Reference Position, Tooling Offset, and Profile Offset for the selected tool. 

PathMaster® – Windows® Operating System based programming software. Used to create, 
maintain and download program files for the workcell. 

Profile Base – A physical device which has a plunger that is used as the Profile Z Reference 
position for all run tools. 

Profile Calibration – The process by which the Profile Offset is calculated for a given run 
tool. This is accomplished by determining the difference of the Z position of the run tool 
and the Profile Tool at the Profile Z Reference. 

Profile Offset – Distance between the Profile Z Reference and the tip of a given tool. 

Profile Plunger Locate – The process by which the Profile Offset is calculated for a given 
Profile Tool. This is accomplished by taking a Profile Tool reading at the surface of the 
Profile Base’s plunger. 

Profile Tool – A tool which may be used to determine the height of a desired dispense 
surface in units of distance relative to a common surface. 

Profile Z Reference – The common surface that is used in profile calculations. Usually, this 
is the plunger of the Profile Base. 

Program – A collection (or series) of Dispense Paths and general commands.  

Program Offset – Change in position that is applied to all programs in all projects. Program 
offsets are generated by Tool Offset Setup, Tool Change, and Needle Calibration. 

Project – File consisting of up to 30 Programs.  

Purge Position – The location in the workspace where the end effector moves to perform 
all auto purge operations. 

PVA –Precision Valve and Automation. 

Run Tool Reference – The workspace position where the run tool is centered above the 
system’s Teach Tool Reference position. 

Standby Position – The rest position for the end effector. The machine moves here after 
homing and after each cycle. This position is usually located near the start point for the 
program(s). It is not the same as the Home Position. 

Sensor Locate Sequence – Establish the spatial relationship between the Needle 
Calibration Reference position and a repeatable location relative to the X and Y sensors. 

Solvent Position – The location in the workspace where the end effector moves to idle in 
solvent cups. 
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Teach Tool Reference – The workspace position where the teach tool is centered above a 
crosshair or other identifying mark. This identifying mark will be used as a common location 
for calculating Tooling Offsets. 

Terminal – A program used as a communication link between the controller and operator. 

Tool – A virtualized instance of a Device, usually configured to a specific orientation. 

Tool Change – Modifying the Run Tool Reference position relative to the Teach Tool 
Reference to change the Tooling Offset. This function is generally used for adjusting a tool 
position after a needle change, tool maintenance, etc. 

Tooling Offset – Spatial relationship between the teach tool and the run tool. 

Tool Offset Setup – Teaching the teach tool to run tool relationship (XYZW) in machine 
parameters. This function is generally reserved for initial tool setup. 

Workspace Reference – A fixed position in gantry space relative to the part fixturing. This 
position is used as a source and destination machine for the purpose of transporting 
machine programs. It may also be used to apply a global offset on all programs in all 
projects. 
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 Appendix C: PathMaster INI Details 

Sections Key Value Description 
[General] Equip_ID String Machine database that is loaded when 

PathMaster Starts 
Default = Default 

Language Enum Enumerated Value representing current 
display language 
1 – English 
2 – Spanish 
3 – French 
4 – German 
5 – Mandarin 
6 – Japanese 

ManualFile Path File Path to PathMaster User manual PDF file 
Default = ‘C:\Program 
Files\PVA\PathMaster\manual\PathMasterMa
nual.pdf’ 

NeedleCalImage Path Path to Needle calibration image that is 
displayed during needle calibration 
Default = ‘C:\Program 
Files\PVA\PathMaster\Graphics\NdlCal.jpg’ 

ProjectFileOutput Path Path to write PartManager project files. 
These files are in DMC format 
NOTE: UserDefaultProjectFileOutput=1 
must be set for this file output path to be 
used 
Default = ‘C:\Program 
Files\PVA\PathMaster\Projects’ 

SpiralSlowSegments Num Defines the number of segments before the 
end of a circular spiral to begin 
incrementally slowing down 
Default = 3 

UseDefaultProjectFileOut
put 

Bool 0 – Prompt User for Path When Saving for 
PartManager 
1 – Use Default Project File Output Path to 
Store Paths when Saving for PartManager 
Default = 1 

EnableAutoBackup Bool 0 – Disable Auto Backups 
1 – Enable Auto Backups 
Auto backups occur prior to changing path 
data as a result of offsets from Setup, Tool 
Change, or Needle Calibration 
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AutoExportPartManagerO
nToolUpdate 

Bool 0 – Do Not Automatically Export (Save For 
PartManager) 
1 – Automatically Save for PartManager 
when Path Data is changed due to Tool 
Setup, Tool Change, Needle Calibration 

MaxAutoBackups Num The number of Auto Backups to save (of 
each type) before overwriting oldest backup 
Default = 50 

SafeZHeight Num Absolute Z position used when teaching a 
move with Approach type ‘SafeZ’ 
NOTE: Approach Type ‘SafeZ’ is 
persistent and is excluded from system 
offsets 

SurfaceUnits Enum Units used by PathMaster for Surface 
Command Min and Max values 
mm = Millimeters 
in = Inches 
cnts = Encoder Counts (200 / mm) 
Default = mm 
NOTE: Enum values are case sensitive. 
Min and Max are always sent to the Galil 
in units of millimeters regardless of this 
setting 

LiveDebug Bool 0 – Do not log debug messages to file 
1 – Log debug messages to time stamped 
file 

NeedleCalLabel String This label overrides any label that specifically 
reference ‘Needle Calibration’ 
NOTE: This key is omitted from the 
PathMaster.ini file and is reserved for 
custom implementations of the calibration 
functionality 

 StartupValidation String Semicolon separated list of labels/variables 
to be checked on startup of PathMaster 

 ThetaDeadband Numeric Tolerance, in counts, of the Theta axis being 
considered “in position” 

[Path] Segments Num Number of Path Segment to use when 
creating 3D Arcs and Circles 
Default = 15 
Max = 511 Segments (DMC2000) 
Max = 2047 Segments (DMC4x00) 

[Vision] LightsINI Path Path to Vision Module ‘Lights.ini’ File 
Default = ‘C:\Program 
Files\PVAPortal\Lib\Vision\Lights.INI’ 
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InspectionsINI Path Path to Vision Module ‘Inspections.ini’ File 
Default = ‘C:\Program 
Files\PVAPortal\Lib\Vision\ Inspections.INI’ 

FidTool Num Tool ID used for Fiducial Function (Used for 
Tool Offsets Calculations) 
Default = 0 

InspectionTool Num Tool ID used for Inspection Function (Used 
for Tool Offsets Calculations) 
Default = 0 

SubroutineTool Num Tool ID used for Subroutine Function (Used 
for Tool Offsets Calculations) 
Default = 0 

[Form] Red 0..255 Red contribution to RGB Background Color 
Green 0..255 Green contribution to RGB Background Color 
Blue 0..255 Blue contribution to RGB Background Color 
Top Num Top Position of Pathmaster On Startup 
Left Num Left Position of Pathmaster On Startup 
Width Num Width of Pathmaster On Startup 
Height Num Height of Pathmaster On Startup 
Border Bool 0 – Open PathMaster with no Window 

Border 
1 – Open PathMaster with Window Border 
Default = 1 

[PMInterface] ToolsINI Path Path to PMInterface Module ‘Tools.ini’ File 
Default = ‘C:\Program 
Files\PVAPortal\Dep\_PMInterface\Tools.INI’ 

Tool Type 0…  Enum Enumerated list of Tool Types 
Default: 
0=Teach 
1=Profile 
2=Non-Dispense 
3=Dispense 
4=Spray (Airless) 
5=Spray (Atomize) 
6=Atom Air Only 
7=Servo 
8=Jet 
 
Note: 
Tool Types in Red (0, 1) are reserved types 
and cannot be modified. All others types can 
be customized as needed 
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[Profile Type] 0…  Enum Enumerated list of Profile Types 
Default: 
0=None 
1=Non-Contact 
2=Contact 
Note: 
Profile Type None is a reserved Profile Type 
and cannot be modified. All others types can 
be customized as needed 

[vRETMsgs] 2…  Enum vRET handshake response messages 
When the vRET response from the Galil 
corresponds to a RETMsg, PathMaster 
presents the message to operator 

[GalilMemory] MaxMain Num Maximum length of Main program in lines 
(80 Char / Line) 
 
Default = 3200 

MaxPath Num Maximum length of Path program in lines 
(80 Char / Line) 
 
Default = 1600 

MaxRam Num Maximum length of Main Prog + Path 
Program in Memory 
 
Default = 4800 

MaxSpiralSegments Num Maximum Number of motion segments 
allowed in a Rectangular or Circular Spiral 
 
Default =1000 

MaxSegment Num Maximum number of motion segments for a 
dispense sequence (other than spirals) 
 
Default = 2047 
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 Appendix D: Working with Materials 
 Overview 

Workcells operate with many different materials in a variety of applications. It is not easy to 
program with these materials because there are no set rules for an operator to obey. The 
best procedure to find system settings for the system is trial-and-error. When satisfactory 
parameters are found, it is easy to maintain those parameters. 

It is necessary to adjust each part of the material delivery system for the selected material. 
Adjust the components in the order shown. 

 Material Feed 

First, refer to the manufacturer’s material specifications to find the applicable settings for 
the material delivery system. Usually, material is moved through the system by a pump or a 
pressure vessel. If a pump is used on the system, read the separate pump manual to find 
the best settings for the material. If a pressure vessel is used, the pressure is too high if 
material flow is too much, inconsistent, or if air is forced into the material. The pressure is 
too low if material flow is not sufficient. 

 Dispense (Needle) Valve 

The stroke of the needle valve can be adjusted. Turn the micrometer knob on the top of the 
valve counter-clockwise to increase material flow. A fine steady stream of material is all 
that is necessary. Tighten the locking nut when the flow is satisfactory. Make sure the 
valve flow rate is correct before you continue.  

 Needle Selection 

Try different needle sizes to find a satisfactory needle for your procedure. If the needle is 
too large, there will be a drip at the end of the needle. If the needle is too small, the flow will 
not be sufficient. 
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 Spray Valve 

Valve stroke and atomizing air are adjustable on spray valves.  

The stroke controls the flow of material through the valve. Turn the micrometer knob on 
the top of the valve counter-clockwise to increase material flow. Tighten the locking collar 
when the flow is satisfactory. Make sure the valve flow rate is correct before you continue. 

Atomizing air is controlled by a pressure regulator on the front of the machine. Turn this 
clockwise to increase air pressure. This pressure can only be adjusted while the valve is 
active. When the flow is satisfactory, push the cap or tighten the locking collar. When first 
operating the machine, follow this list of instructions to adjust the spray valve: 

1. Set the atomizing air to 0 psi. 

2. Take off the spray cap. 

3. Turn the stroke down all the way. 

4. Purge the valve and open the stroke until the flow is a few drops per second.  

5. Put the spray cap on. 

6. Purge the valve and adjust the atomizing air until the spray is satisfactory. Test the 
spray pattern on scrap. 

If the atomizing air pressure is too high, the spray will be misty. If it is too low, there will be 
splatter. For thin, solvent based materials 0.5 psi may be all that is necessary, and with 
some silicones 15 psi may be necessary. 

 Programming 

Once the satisfactory physical parameters for the delivery system are set, do not change 
them. It is better to change the program. Usually, if you increase or decrease the speed of a 
dispense path, the material output changes to a satisfactory level. 

Program with the dispense valve close to the part surface, but not so close that different 
needle length tolerances will cause the needle to touch the product surface. 

With the spray valve, start about ¾” (19 mm) above the product surface. With atomizing air, 
this should produce a spray width approximately ½” to ¾” (19 mm) wide. If necessary, 
adjust the spray height so the pattern on the product is consistent and uniform. 
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 Appendix E- Optical Bonding with PathMaster  

 Theory of Operation  

Optical bonding with PVA’s PathMaster software should be done with the bonding path 
template as shown in this document. This document only refers to bonding specific 
settings. Please refer to the PathMaster manual for additional information on PathMaster.  

PathMaster uses a series of plugins to set values for your specific procedure. Please set all 
of the plugin values before you program additional template values.  

Path Template 

The easiest way to create a bonding sequence is to use the bonding template and change 
the values as necessary for your product and process.  

• You will need to import the path template from the '\PathMaster\Samples' folder on 
the workcell computer. For additional information on how to import a path, refer to 
the PathMaster manual.  

 Plugins  

There are two types of plugins, Setup plugins and Path plugins. Setup plugins are for 
machine setup purposes and must be completed before a production path can be run. Path 
plugins are program specific. In the case of bonding equipment, setup plugins are used to 
measure the positions that are described in the name of the plugins. The wizard plugin 
uses the values from the setup plugins to establish the bond base position and the bare 
pick head reference measurement height. The descriptions of all setup plugins are in this 
document, for information on the path plugins refer to the PathMaster manual. 
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Setup Plugins  

You must set the reference positions before you can create a bond routine. The Setup 
Plugins have the four main steps that you must complete to have a succesful routine. The 
setup plugins must be done in numerical order (1-4). 

Offset values should be taught to the bare datum and pick tool. The part values you set will 
calculate the correct distance off of the datum and pick tool.   

NOTE: The setup plugins are used to calculate the bonding reference position. Setup 
plugins are accessed through the PM machine setup menu and have a global effect. 

1. Select Setup->Machine Parameters from the Main menu to open the Machine 
Parameters window. 

2. Select the “Functions” button form the Plugins section of the screen. 

 

Figure 195: Plugins, Functions  

3. The Setup Plugins screen will open. Use the radial Sort By buttons to sort by 
Category.  

4. Do the four “Bond Setup” plugins in order. 
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Figure 196: Setup Plugins  

NOTE: Plugins must be done in numerical order, as shown. If done out of order, the setup 
window for the plugin will close and you will return to the previous screen. 

 HeightTool to Datum 

1. In the Bond Setup category, select 1-HeightTool to Datum.  

The HeightTool to Datum window will open. 

 

Figure 197: HeightTool to Datum 

2. Refer to the instructions in the window to set the correct position.  
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3. Use the teach pendant to teach the value; push the “Teach” button and release the 
button to record the value. 

 

Figure 198: HeightTool to Datum Instructions 

4. Select “Done” to save the values and return to the Setup Plugins window. 

 PickPlace to HeightTool  

1. After the HeightTool Datum, select plugin 2-PickPlace to HeightTool. 

The PickPlace to HeightTool window will open. 

2. Refer to the instructions in the window to set the correct position.  

3. Use the teach pendant to teach the value; push the “Teach” button and release the 
button to record the value. 

 

Figure 199: PickPlace to HeightTool 

4. Select “Done” to save the values and return to the Setup Plugins window. 

 HeightTool to Plunger 

1. After PickPlace to HeightTool, select plugin 3- HeightTool to Plunger. 

The HeightTool to Plunger window will open. 

2. Refer to the instructions in the window to set the correct position.  
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3. Use the teach pendant to teach the value; push the “Teach” button and release the 
button to record the value. 

 

Figure 200: HeightTool to Plunger 

4. Select “Done” to save the values and return to the Setup Plugins window. 
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 Bond Offsets Wizard 

1. After the other three bonding plugins have been setup, select the Bond Offsets 
Wizard. 

 

Figure 201: Bond Offset Wizard 

2. Select the “Start” Button. 

 

Figure 202: Make Sure Pick Tool and Datum are Empty 

3. Select the “Next” button when the datum and pick tool are empty.  

 

Figure 203: Teach the HeightTool to Datum Reference Height 

4. Use the teach pendant to teach the HeightTool to the Datum Reference Height. 
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Figure 204: Datum Reference Height 

The “Teaching, Please Wait” screen will be shown. 

 

Figure 205: Teaching, Please Wait 

5. Next the HeightTool to the Needle Cal plunger is taught. The height is automatically 
detected by the wizard, there is no user input.  

 
Figure 206: Teach HeightTool to Needle Cal Plunger 

6. Click “Next”. The Teaching, Please Wait screen will be shown.  
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Figure 207: Teaching, Please Wait 

7. Use the teach pendant to teach the center of the needle calibration plunger as 
shown on the screen. Use the teach pendant to make sure the crosshair is in the 
center of the indicator dot. When the crosshair is correctly aligned, push the “Teach” 
button on the teach pendant.  

 
Figure 208: Teach the Needle Cal Plunger Center 

 

Figure 209: Portal Front Panel Screen, Needle Calibration for Plunger Center 

8. Next, to turn the door bypass to on. 
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9. Install the threaded spike on to the pick and place tool. Turn the threaded spike 
clockwise until it is tight, do not overtighten.  

 
Figure 210: Install the Threaded Spike 

10. When the threaded spike is installed, click the “Next” button. 

11. Use the trackball to move the spike directly over the center of the needle calibration 
plunger.  

12. Push the “Teach” button when the position is correct. 

 
Figure 211: Teach the Needle Calibration Position 

 

Figure 212: Position Taught Screen 
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13. After the position is taught a confirmation screen will be shown for the X and Y 
positions Select “Next”. Another screen will confirm the Z-position.  

 
Figure 213: Remove Threaded Spike 

14. Turn the door bypass “Off” and open the door. 

15. Turn the threaded spike counterclockwise to remove it. 

16. Close the door. 

17. Select “Next”.  

 Center of Rotation 

1. When you hit the “Move to” button the camera goes live and feed is displayed in the 
vision tab.  

 
Figure 214: "Move To" Button 

2. To teach the center of rotation, use the teach pendant to move the X,Y location so 
that when you move the W-axis the exact center of the image is stationary and 
everything is rotating around it (center of rotation).  

3. When this location correct push the “Teach” button on the teach pendant.  
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Figure 215: Center of Rotation 

This will update the Galil resource associated with the center of rotation for the W-axis 
relative to the camera.  

4. Select the done button. The camera and light will turn off.  

 Part Thickness 

Use the Part Measurement plugin to set the part thickness. You must do this for both the 
substrate and the component.  

1. In PathMaster, select Plugins->Part Measurement from the main menu. 

2. When the Part Measurement window opens, select the “Perform Check” box. 

3. Select Substrate or Component from the Operation drop down menu. 

4. Highlight the section of path that has the Part Measurement plugin and run it in 
manual mode.  

After the check is done, the Part Thickness value will be shown on the Portal screen.  
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Figure 216: Measured Thickness 

5. Enter the value in the Part Thickness box. 

 
Figure 217: Part Thickness in mm 

6. Deselect the “Perform Check” box. 

 
Figure 218: Perform Check Box 
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 Path Template  

After the Setup plugins for bonding are done, the next step to make a new bonding routine 
is to go through the Path template and set the values for your specific parts. Refer to the 
Bonding Path Template for more information.  

NOTE: When possible, please use part and material values from the manufacturer.  

1. Make sure the Path Template values are in the correct order with the correct values 
set.  
• Set part dimensions. 
• Teach the part pick offset. 
• Set the part thickness. 

2. Highlight the section of the path that includes all of the above commands.  

3. Run the highlighted section of the path.   

After the you have successfully run this section of the path, continue to program the 
following sections. 

• Program the part inspection (Substrate). Double click on this in the Path 
Template and the plugin will open.  

• Program the part inspection (Component). Double click on this in the Path 
Template and the plugin will open.  

• Measure the Component height. Double click on this in the Path Template and 
the plugin will open.  

• Program the part pick. Double click on this in the Path Template and the plugin 
will open.  

• Program the underside dispense. This must be taught to the bare pick tool. 
• Program the dog bone dispense. This must be taught to the bare datum. 
• Teach the prebonding move. Double click on this in the Path Template and the 

plugin will open.  

When you have completed these steps continue to the Bond Manager section (24.4). 

  



 
Machine Operation Manual 

 

Revision L / February 2020 Page 195 of 200 

 

 Bond Manager 

After all of the Bond Setup plugins have been run, the path template values have been set 
for your parts and the part inspection has passed, you can use the bond manager to create 
the Bond Manger recipe.  

1. Select Teach->Bond Mgr from the main menu. 

 

Figure 219: Teach Menu, Bond Manager 

2. The bond manager window will open. Set the Routine Name. 
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3. Set the values for Approach distance, Material Thickness, Speed, Acceleration, and 
Deceleration. 

 

Figure 220: Bond Manager Recipe 

4. Make sure Setup Mode is set to “Teach” and Select the “Begin” button.  

 

Figure 221: Bond Manager "Begin" 

The Initializing screen will be shown. 
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Figure 222: Bond Sequence, Initializing 

5. Press and hold the “Teach” button on teach pendant to record the first bond step. 
Release the “Teach” button to stop the motion and start to record the first dwell. 

 

Figure 223: Teach Bond Sequence 

The Step Number, Material Thickness, Approach Distance, and Remaining Distance are 
shown when a step movement is being recorded. 
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Figure 224: Teaching in Progress 

The Dwell time is shown when a dwell step is being recorded. 

 

Figure 225: Current Dwell 

6. Repeat the procedure to record additional bonding steps. The values will be shown 
in the table.  

7. Press the “Axis” button on the teach pendant when the wet out is complete. This 
will save the value. 



 
Machine Operation Manual 

 

Revision L / February 2020 Page 199 of 200 

 

 

Figure 226: Material Wet Out 

The screen below will be shown when the complete bonding sequence has been taught. 

 

Figure 227: Bonding Complete 
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Bonding in Auto Cycle  

When you use Auto Cycle to make parts, the follow screens are shown in Portal.  

 

Figure 228: Bonding Cycle Running 

When the part placement is complete the following screen is shown. 

 

Figure 229: Place Routine Complete 

Additional steps of the bond cycle are customer specific and may have additional screens. 
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